Side loading Companion app on Hammerhead Karoo 2

Finally did it and it’s 98% brilliant the layout needs a little work as it isn’t designed for this small screen but now my power up and messages are on my handlebars! Love it!!

I have it installed on mine as well but rarely use it, exactly because the layout looks so fugly. (I do like the possibility to buy train tickets on the Karoo, though…)

I don’t think it look’s ugly at all? :man_shrugging:

is too just much for me (and there’s very little left for the actual map in the map view)…

1 Like

Hi, how do I actually install it on my Karoo 2?
Thanks and happy new year! :partying_face:

Short version: enable developer mode by tapping build number under Settings - About umpteen times, then use Android developer tools on your computer to upload the .apk file to the Karoo via USB. Longer version:

I only installed ApkPure like this and other apps via it so I can install and update additional apps without dev tools.

I eventually succeed in side loading the Companion app. I use it on every Zwift ride, for watts/kg.
Do you know if you can easily install updates to the app easily?

At least via ApkPure updating is not too bad, you still have to do it manually but it is pretty much like how it works on iOS or Android if you have disabled automatic app updates. The difference is that you have to update each app one by one so it’s an extra tap or two per app. (Disclaimer: using a third-party service like ApkPure may make your device more vulnerable against malicious software.)

If you just copied the Companion .apk itself to the Karoo with adb, then I believe the update process is basically the same as the installation process.

Hi. I have been using the Zwift Companion sideloaded on my Karoo2 via adbLink without a problem for about 6 months until last week. I was using version 3.26 of the Companion app the entire time, but last week when I opened the app is said that this version was no longer supported, so I updated to the then-latest version (3.34.1). After I did this, I can enter my login info but then it seems to freeze on the login screen. When I restart the app, it gets stuck on the blue “Z” screen. Zwift just updated to version 3.35, but I still have the same problem (even after doing a factory reset of my Karoo2). Not sure if this is a problem with the Karoo2 after the latest software update or with the Zwift Companion app. Anyone else having this problem or have any ideas how to fix this?

Thank you!

Sadly the same thing it’s happened to me and I haven’t been able to figure it out yet. Hammerhead has their own support forum that you could ask or there’s a number of Hammerhead pages on Facebook that you can search as well unfortunately I’m just too busy to put the effort into it right now.

I’m seeing similar reports on the Hammerhead support forum (I posted my experience as well). Still not sure what the problem is, but here are a few more details of my experience (that I shared on the Hammerhead thread).

On April 19th, I tried using the Zwift Companion app and it said that my version was too old and needed to be updated. I updated to the then-latest version 3.34.1 and was able to enter my credentials, but it gets stuck. I force close and when I restart it’s stuck in the blue screen with the Z-logo.

I tried going back to an older version of Zwift Companion and I’m able to enter my credentials, but then it comes up with the screen saying that the version is too old and I need to update. I did a factory reset on my Karoo 2 and the problem persists.

I used the Companion app on March 28th without any problem. My next attempt was on April 19th, when it failed. So the problem seems to have started sometime between March 28th and April 19th. I regularly update my Karoo 2 software, so I’m not sure if one of the intervening updates caused this problem or this is a problem with Zwift.

It’s odd that I’m able to enter my credentials with the older version of the Companion app (even though it just says that the software is out of date and won’t let me do anything). Could it be a problem with the new Zwift app not working with the side loaded Companion app?

Hopefully we’ll get this figured out. Even though the screen size/formatting was a little bit off, I loved using the Companion app on the Karoo 2.

Sadly I’ve tried various methods of uninstall/reinstall, updating, etc. and this is still dead in the water. It’s a shame as this was a brilliant pairing.

As @Shane_Miller_GPLama has noted elsewhere, it won’t work past August anyway since it runs on Android 8 which ZHQ is killing off.