Companion App - issues since update


Hope I am in the right place. I use a laptop and my mobile phone (Samsung – Android)– companion app (android) connected by Bluetooth to my Wahoo kicker for Zwift. I have noticed since the Zwift update in July that my Companion app now takes a lot longer to load on my phone – it used to open immediately before – but the main issue I have with the app is that when I am riding in an event the app sometimes shows the power ups (that’s the icons in the top with feathers and draft icons etc) sometimes it doesn’t, and if they do show on the phone screen if I press them to activate – they do activate but the white line around them doesn’t move – it does on my laptop – if I get a new power up the new one shows on the computer but the old one stays the same on the companion app – it does active.

I’ve uninstalled and reinstalled the companion app on my mobile several times but still no different. Hope this is understandable - is there anyone out there having similar issues or has a fix or any ideas of what I might be doing wrong. I’ve not had any issues prior to the July update. PS on the companion app on the android is says Version 3.16.0

Loading has slowed and I have had instances where its just not loaded, since last upate. I dont bug Zwift about it as I want them to focus on another CA app issue a few of us have that got broken about 2 years ago :rofl: :crazy_face:

I too am having trouble with the companion app on Android. I’ve been riding outdoors since the last update and tried to ride Zwift yesterday and today. I updated the Zwift program on my Mac and installed new companion app on my Android phone.

The only way I can get my phone to connect to the game is by restarting my phone and then opening the companion app. The game part appears for about 30 seconds or so and then the map on the game stops moving. I can’t control any functions of the game from the app. The app is still running since I can go to the home screen, etc. The game part isn’t connected anymore.

Does anybody know of a fix for this or is there some other place I should be posting this question?

Many thanks!

Quick update. I reinstalled the app and rebooted my router and it is working.

1 Like

Since the last release the App simply disconnects/hangs during a workout. I’m using the Companion App as a head unit while running the Zwift on a computer.
It’s really frustrating when digging deep and this app fails and I’m question the extent of the software testing performed?