Saris M2 resistance control running behind

Within the last week, the controlling of the resistance is lagging behind what the hill grade is in the game on my Saris M2. It is behind by at least a minute. I’m connected via Bluetooth and it says the connection is fine and strong. I tried to connect via Ant+ and the resistance doesn’t change despite it saying it’s connected. Re-callibrated trainer on the Saris app and still having the issue. Firmware on the trainer is Magnus 16093 V31.062. I can still use the trainer, but it really messes with the brain when what’s on the screen doesn’t match what the trainer is doing. Any help would be greatly appreciated.

Same here. I bought my Saris M2 last week and had troubles calibrating the trainer, which is not a Zwift issue btw.

Today I took the trainer to the test and rode a 5km ride (NYC Loop) to check if the calibration process would do its job. Climbing and descending felt odd because I couldn’t determine if something was happening with the resistance. During the ride I changed the, how do you call it, ‘resistance option’ from easy to somewhat harder. After a minute or 2 I finally felt some resistance, but with a lot of lag.

Is this related to the trainer or Zwift?

Hi Alex,

I did get some help that worked. Here’s their instructions; these are written for the file structure on a Mac, but I believe the filenames (if not the locations) are the same on Windows machines.

I recommend that you delete the prefs.xml and knowndevices.xml files from your Zwift folder. These files store your in-app preferences and information about devices that you’ve previously paired. Occasionally, these files can hang on to incorrect information, such as a wrong trainer selection, or a device paired in the wrong spot (e.g. a speed sensor paired in the cadence spot).

Modifying the files in your Documents/Zwift folder can also have unintended consequences, from your avatar appearing on the wrong course to display issues, or being unable to pair your devices, and is something that we generally don’t recommend. When these two files are deleted, they will regenerate fresh copies the next time you launch Zwift.

Here’s what you’ll need to do:
1. Exit and close Zwift. Make sure Zwift is closed from your your dock as well.
2. Open the Documents folder on your computer.
3. Open your Zwift folder.
4. Delete the files named prefs.xml and knowndevices.xml, then close these folders.
5. Launch Zwift again and pair your devices in the correct spots on the Zwift pairing screen, then go for a ride.

I had so many issues with the M2 connection and clutch knob that I ended up returning it and getting a wahoo trainer.

Good luck,

Hi Jess,

Thank you for the reply. I use Zwift on a iPad Air through BLE (Bluetooth). I haven’t tried it on my Windows machine yet.