Saris H3 intermittent missed power changes in ERG mode


I have noted an intermittent but often recurrent issue which only occurs in Workouts in ERG mode on my Saris H3 smart trainer. Just wondering if others have experienced this and if it can be solved. I’ve been having this problem since getting my smart trainer. I have not had an opportunity to try any other smart trainer.

Equipment specs:

Saris H3 smart trainer, AppleTV, iPhone (different ones) for Zwift companion app, CABLE bluetooth bridge for Saris, cadence sensor and HRM. All firmwares and Apps up to date. All connections are working perfectly, never any sensor drops. Strong high speed WiFi. I’m quite sure that I have ruled out connectivity as the issue. Same thing happens whether or not I use Zwift companion app as the bridge.
My system otherwise works perfectly in free ride mode. The trainer responds normally and feels quite realistic with the terrain.

Here’s my issue:

During a workout, when a new interval changes the power (especially if a big change, either up or down), my Saris H3 trainer will continue using the same resistance and forcing me to put out the same power as the interval which just finished. For example, I’ll be in a recovery at 120 W, the next interval is 200 W and as my Avatar goes through the arch, my trainer still only allows me to put out 120 W, so I end up spinning very fast to try to get more power but I don’t get more resistance from the trainer.

This only happens sometimes and more so if I maintain steady cadence as I ride through the arch on the screen. If I slow down my cadence as I go through the arch, wait for the trainer to feel more heavy, and then start pedalling, it happens less often.

Things I have tried, (none of which have made any difference):

  1. Updating all apps, firmware, calibrating the trainer many times.
  2. Using a different bridge or no bridge (I use a bridge because AppleTV only allows limited bluetooth connections so if I use no bridge, I have to set the cadence input to the trainer which is less accurate).
  3. Changing trainer difficulty in Zwift settings. Currently it’s set in the middle.
  4. Using various gear configurations on the bike, set at the start of the workout (I very rarely change gears during an ERG workout unless it’s a huge power sprint effort).

When this problem happens, the quick bandaid fix is to turn Erg mode off and then back on again after 1-2 seconds (in companion app). The trainer will then give me the correct resistance and power.

As mentioned above, I have found that I can prevent it from happening usually by slowing my cadence right down just before an arch and then waiting a second before peddling up again. This is rather annoying to do in certain situations such as a brief power surge interval.

Sorry for the long post but I wanted to be as detailed as possible. Thanks in advance to any comments/solutions/explanations shared.

Ride On!

Very strange. Fwiw, I have a Saris H3 and have never experienced this problem after many (hundreds?) of erg workouts. I have used an Apple TV 4K in the past, although now I use a PC w/GPU.

About how often does this happen? every workout? One in 10?

Random trouble shooting thoughts:

My first thought is eliminate the Cable (to minimize variables) for a few rides and also move your Apple TV as close as possible to your H3 on the non-drive side. I say non-drive side because iirc the Bluetooth antenna on the H3 is near the flashing LED. Is your Apple TV a relatively recent model, aka an “Apple TV 4K” or later? Maybe the older non-4K models have trouble keeping up with the load of running Zwift. Do you always have the problem in the same world? Makuri is a lot more cpu intensive than other worlds. If you can reproduce the problem pretty regularly (perhaps by using a workout with a lot of interval changes), another option to try would be use your iPhone to run Zwift instead of your Apple TV (suffering the small phone screen for a workout or two).

You mentioned you tried eliminating the Cable and also tried using the Bluetooth connection via the companion app…. Did you try both at the same time, or when you connected via Companion were you still using the Cable? Maybe try Companion without the Cable….

Has this always happened, or did it start recently?

Good luck and hope you get this sorted!

Hi Todd.

Thanks so much for your helpful response.

The problem happens quite often, I’d say at least once every few ERG workouts and sometimes several times in the same one, nearly always when there is a large power change between intervals, either up or down. But mostly it doesn’t happen at all. Also, it has happened in all the riding worlds. Intermittent issues are the hardest to figure out.

I should have specified, I have Apple TV 4K. Unfortunately, due to our room layout, my trainer has to be about 12 feet away from the ATV which was one of the reasons for the BT bridge; my HR monitor would not connect properly to the ATV. I have tried using Zwift companion app alone, or along with the CABLE device as well, and the problem has been the same.

Your response made me realize something though: I have not tried using the bridge ONLY for my HR and cadence sensor, and connecting the Saris “DIRECTLY” (via BT with no bridge at all) to the Apple TV 4K.

Today, I connected the Saris H3 to “Power Source” and “Controllable” (both showed full green signal bars), and then the CABLE to HR and Cadence. It worked flawlessly with no missed power changes in my test workout!!

It’s only N=1 so far but fingers crossed. I guess the BT bridge occasionally interferes with the power control signal getting back to the Saris?? Weird.

Anyway, again, thanks for your help and I’ll give an update later after some further workouts.

I have done quite a few workouts without using the Bluetooth bridge to connect my trainer to the Apple TV 4K and I have not had a single power drop. I’m happy to say that this issue is solved.

The key is to connect the trainer “POWER” and “CONTROLLABLE” by direct BT connection to the ATV without any kind of bridge.

1 Like