Running level 19 not showing up in the companion app (iOS)


(Fusion) #1

Title says it all. I have passed by several kms running level 19, but the companion for iOS still show level 18.

Logging out/in didn’t change anything.


(David K) #2

Yeah, I’m noticing that. It looks like your last login does show you at Running Level 18 with experience of 67,155; but at 67,000 running experience, you are supposed to gain level 19.

Is there any possibility you’re running Zwift on more than your Windows 8 PC? If you have any other devices running Zwift and you’re logged into your Zwift account from them, they can keep other devices from properly uploading your activities. It may be helpful to log out of all of your Zwift devices, give them a quick reboot, and try logging back in ensuring you’re only logging into your Zwift account once from Zwift and once from Zwift Companion.


(Fusion) #3

I have been using only a single Win10 system for months, but I have checked other iOS devices as you mentioned, and it didn’t help.

When running in Zwift I do see I’m at L19, but it still shows at L18 in the iOS Companion.


(David K) #4

I’m definitely seeing that an iPhone 10 logged into your Zwift account yesterday (6/24/2018). It’s likely your activity isn’t uploading from your Windows 10 PC to our game server because the iPhone 10 is still actively logged in. When multiple devices are logged into the same Zwift account at the same time, levels and experience isn’t updated until the last device logs out.


(Fusion) #5

Just reached L20 and I still have the problem. The only application I use on my iPhone is the Companion, so why is it interfering?  It makes no sense as it has nothing to do with updating the counters.  Looks to me more like a design flaw or a bug.


(Fusion) #6

Zwift.exe still reports the data just fine, but for some reason, you are not using the same application logic in the Companion under iOS. Both are communicating over the Internet to your central database(s), so it just doesn’t make sense. The Companion obviously has a bug and/or is using defective application logic.


(David K) #7

Zwift often won’t upload new activities to our game server if several devices are logged into the same account at the same time. Also, Companion won’t display correctly if it’s running on the same device you have Zwift installed on. I’d suspect if you were to log out of all of your Zwift-related apps and log back in, Companion would display correctly.


(Fusion) #8

I did that, but it’s not working.


(David K) #9

Since your initial post, we have had a few members write in with similar concerns. We’ve been told the discrepancy between Zwift and Zwift Companion should be resolved with the last update that went out a few days ago. Is Zwift Companion still showing the incorrect Running level?


(Fusion) #10

Still no joy for me. As of today (Jul 30th), I’m now 1/2 way L20 for the running in the app, but still showing as 3/4 L18 in Companion 2.3.2 (445).

I tried login out/in of the Companion too.