Run/app crashing on iPhone mobile app [SOLVED]

Hello i just received my runpod and my app has been crashing every time i am trying to get in a workout. Its kind of frustrating. Bike is working well.
I have a iphone 11 pro max and my mobile app has been working well since day 1. Please help me !!!

Hello @Alexandre_Labonte_43
Welcome to Zwift forums!

On the Run side: what device are you connecting to?

Make sure the firmware is up to date on the ZwiftPod.

Assuming it is a Zwift runpod: the fix is coming in the next game release.

This bug was fixed in the January 2 2020 release. Should anyone see the game app crashing on iOS moving forward, please let us know.

Hi, I’ve tried three times today to connect to runpod but it crashes the iPhone app. My bike connects no problem but not the runpod. Is there an issue at all or is it the runpod?

Is your iOS and Zwift app fully up-to-date?

I literally deleted and reinstalled the app and it still wouldn’t work. iOS is up to date too. I had the run pod for Christmas and managed less than 10 miles because it keeps crashing the app. My Tacx smart trainer for my bike doesn’t crash the app

What is the model of the iPhone and the iOS version?

What is the version number of Zwift you are running?

iOS 13.3.1 on iPhone 7. I assume it’s the latest Zwift app as I reinstalled it about 50 minutes ago

Does the Zwift RunPod connect and when you start running the Zwift App crashes?

If so you could click on the Wrench on the Pairing Screen and see if there is a firmware update for the RunPod.

1 Like

Ah ok I’ll try that. It connects no problem but as soon as I enter the chosen world, it crashes after about 2 or 3 seconds whether I start running or not. I’ll try to see for an update and report back!

1 Like

HI @G_Perkins

What worlds are you choosing for your run sessions?
After the game app crashes, look in your System tray: is the app still in your systray? If it’s still in the system tray, it’s likely that there’s not enough available memory. Maybe try rebooting and reduce any memory load. In particular, check that Chrome is shut down completely because it’s a memory hog.

Sorry I’m that technically minded but it’s on iOS? If by system tray you mean if it’s still working in the background then no, it completely shuts down. I’ve mainly tried Watopia but also tried London and Richmond. I have 6.5GB free space on the phone (I have it running via lightning cable to a big tv) and it was the only app in use at the time.

@G_Perkins sorry - I’m using non-Apple jargon.

Can you switch to the Zwift game app if you press the home button as described in this Apple support page?

1 Like

Ah right. No, it completely closes it down

Hm. That’s not what we were thinking is happening.
Our QA team will investigate. Can you give us a day or two? We thank you for your patience.

No problem…I’ll use the turbo trainer instead! Thanks for looking

This is a tough one to diagnose from our end. We’d like you to send the log files on your iPhone to us so we can look at what’s happening on your end.

  1. Please locate your log files following these instructions.
  2. Email the log files to Do not copy & paste the text inline - attach the multiple .TXT files please
  3. In your email, please ask for Shuji and it’ll get them to the right team.
  4. Please also reference this forum thread URL
    Run/app crashing on iPhone mobile app


Thanks Shuji, I’ve sent the email for your attention