Routes do not work

I’ve noticed that sometimes the route selection does not work. I was trying to achieve some of the new course badges and selected the “Three Sisters” route on the start menu and started riding; at the first intersection just past Down Town the program suggested that I take the left hand turn to the Sequoia Circle, instead up the KOM Climb as the route should go. I had to manually steer that way.

Same thing happened a bunch of time on different routes, where you expect to go one way to automatically follow the selected route but the program send you another way, off course.

I am experiencing similar problems with routes not giving me credit due to Zwift taking me off course from the route I selected.

Nice pic bob :slight_smile:

I am seeing the same. Yesterday (29Nov) and today (30Nov) I selected the Everything Bagel in NYC and both times only got Park Loop.

The everything bagel and park park loop share the same piece of road. Just continue riding without turning and you will do the everything bagel.

Gerrie, thank you for your response! Today after selecting the Everything Bagel as my route, I rode for 22 miles and only did the Loop: more than twice and only one direction (just clock wise). I am using a 2017 MacBook Pro, running the latest OS X patch set (Catalina). Zwift version is 1.0.42346. Launcher version is 1.0.11. I have auto update on.

Maybe it was counter clock wise, but I definitely never turned off of the perimeter loop (no ball park, no Astoria, no KOM).

Looking at your activity you are correct, that is the park loop.

I am doing the Everything bagel as we speak and it all seem good to me, within 3km I am on the first KOM.

I am on Windows.

I’ve had the same issue. Am I missing something?

Same issue as? What route did not work?

Tried to do the park perimeter route in NY. Routed me somewhere else.

Have they gotten around to fixing the Surrey Hills Route badge? It has been a known issue for a while now. Some found a work-around by turning around after the final trip up Fox Hill and crossing the line, then doing that again, but it didn’t work for me either way. Would be nice if they would announce if it was fixed so we don’t have to guess.

I’ve also experienced this issue, so much so that I stopped bothering to select routes as, unless I memorise every route to make sure the direction decisions were correct, it was pointless. It’s good to know that I’m not the only one this happens to but it is very frustrating and is a feature that I’d like to use. Is there any update from anyone on whether this is due to be fixed, or if it is even being looked at?

Hi @Tim_Varney.

welcome to the forum. It is not that the route take the wrong turns, it is sometimes the route start after the banner.

But I think most of this have been fixed, so far I got all the badges that I attempted.

I have also seen people that got all the badges.

Make sure your Zwift app is alway on the latest version.

1 Like

Thanks @Gerrie_Delport, appreciate the update. I’ll give it another try then as it’s been a while since I tried and sounds like it might be fixed! :crossed_fingers:

Thanks again,


1 Like

I have also found that it has been fixed!

Ride on!