Zwift ignores my route choices

I find that I choose a route on Zwift, normally to Just Ride, and it ignores me. For example, I’ll choose one of the short Harrogate loops, but find myself doing the full circuit. I’ve seen a few posts where the problem is that the title that comes up is misleading, for example topic 1333 “Cannot change route” (I’m not allowed to link even internally to that, which is odd!)

However, in my case, the autopilot actually takes me round that full loop.

Given the way that responses to 1333 describe how titles are used, there’s no way to know which ride I’ll actually do except to go all the way round, and then it’s hard work knowing what I’ve done, but the Harrogate full loop is easy to spot and several times further round than some of the short loops. For a start, the full loop goes out of town and through at least two valleys, whereas the short ones don’t.

I have managed to do several different rides in Watopia.However, even then it’s unpredictable. For example I have just chosen Jungle Route and ended up on Repack Ridge, which doesn’t look right at all. Choosing Hilly Loop always works! In most cases, though, a world will have a default route and I land on that every time, regardless of what I choose. Which is what is happening with Harrogate above.

I believe that some routes are limited by rider level, but only I think up to about level six?

Good morning @oldandslow.

Can you please walk us thru how you select routes? Are your system up to date. Do you make manual turns?

1 Like

No manual turns. Yes, systems up to date. I normally use Android. I have now installed Windows, but with no sensors - so I can use it to test, but not actually to ride. The results on Windows and Android are the same. I have never yet made any manual turn.

Route selection: choose a world. Click on the desired route. This is confirmed on the next screen, where I am back to the page where I can choose a world. This time I chose Ven-Top from France. But when I pressed Ride I was on Marina Sprint, which can’t be right as there is obviously no marina on that route.

That sprint is just before the start line so you may have seen it because your spawn point was in that section.

1 Like

I think you are confusing leader boards with routes. Most all of the routes do not have a progress bar at the top of the screen with a few exceptions such as the hilly route on Watopia. Once you choose a route there is no indication in the game that you are on the chosen route. As you come to sprint and KOM segments a leader board appears on the left side of the screen for a short time.

1 Like

Mike - thanks. But, as I said, I’ve tested this by doing the full ride (with no manual turns) - as in my Harrogate example above.

I agree that I tend to assume that the leaderboard will refer to the current route, and it doesn’t - which is pretty much what 1333 describes I think. But I’m finding that I choose a route and still get taken round the wrong one, so I don’t think that that is the problem.

(It’s a separate problem that there is apparently no easy way to know which route you are on, except to ride round it and then try to guess from the map or similar!)

can you link to your ride report from your example? The only time I have seen Zwift put someone on the wrong route is during a Meetup when Meetups were having issues, especially in New York, but I think that was fixed.

1 Like

I’m not allowed to include links but the activity number is 612305853550272384 - does that help?

Yes, I see it, and if you chose the UCI worlds Harrogate course, it looks as though that is exactly what route you rode. What makes you think you didn’t complete the correct route? Which one did you choose?

1 Like

Duchy Estate. I was looking for a short warm-up before going on to a longer route. May have tried for Queen’s Highway as well, when the first didn’t seem to be working. As I described above, it doesn’t much matter what I choose, I end up on the same route every time.

Are you aware of the lead ins? They are quite long on these routes.

1 Like

I’m aware of lead-ins. But, as far as I know, no Yorkshire course has a lead-in that goes more than a full lap of the UCI World’s course. I rode more than a circuit of that, starting at the bottom of the hill where I spawned, and finishing by passing under the banner at the top of the hill after just over one full lap. I know that circuit because it’s an extension of the Pennypot Lane one that was used over 40 years ago at the Harrogate Festival of Cycling and other events.

Please forgive me for asking, but this is confusing me, so I’m probably missing something.

You say that on Windows you didn’t have any sensors. How did you move your avatar on Windows in order to test?

I didn’t. I did that on Android. But I checked that, on Windows, I also spawned in unlikely places, such as a marina for a route that doesn’t go near the sea (see above for France example).

@oldandslow You will see a Marina Sprint leaderboard appear on screen at the start of the Ven-Top route, and you can confirm via GPLama’s Ventoux & Chill video. I don’t think you actually do the sprint segment (have to double check/confirm—are you technically in part of the segment upon coming out of the starting pens?), but the marina is not far behind you as you come out of the starting pens.

I would try reinstalling Zwift on your Android setup. Delete it and install it again.

As others have said, you’re confusing the leaderboards with which route you’re on. Ignore the leaderboards and just pay attention to the roads that you’re actually on, then it would give more helpful information as to what might be going wrong.

I think the Jungle Route is level limited, there is a gate as you turn right (instead of left up the KOM) but can’t remember which level it unlocks at.

It was reduced to level 5 a few months ago and the Alp was reduced to level 6.


Ok, cool.

Not that causing your problem then…

Steve - thanks. I will try an Android reinstall. Won’t be on Zwift though to try it for a couple of nights, as I rode a real, actual, socially-distanced club 10 tonight :grinning: