Rider not moving when pedalling

Hi riders

Any help would be much appreciated…

I went to ride my bike on Zwift today, for the first time since 9 November 2019. I have a Tacx Flux and use ANT+ to connect everything. However, the rider doesn’t move and the only information showing on the screen is my heart rate. When connecting there are two options shown to connect for “Power Source” and “Cadence” which are “Tacx Pwr-100” and “Tacx FE-C100”. Under the “Controllable” option the only option is “Tacx FE-C100”. I’ve tried the different options, but nothing! I’ve updated the Tacx Flux trainer as an update was needed too.

I’ve also checked to make sure my subscription payment is still being paid which it is.

Power is going to the Tacx Flux so it’s nothing as simple as that.

I’ve closed down Zwift and restarted it but nothing.

Any help or suggestions would be much appreciated.

I had this issue on my hammer…had to turn off companion and link directly through apple tv. Which meant no HR, but I at least my avatar was working!

Thanks Mark, just tried this and still nothing…

It happen to me,I just keep pedaling and it seems to catch and I go on and finish, who knows what happens I have been told it some internet problem but???. good luck

I have been struggling with this for a week & finally found a simple solution.

Zwift directly uses bluetooth to find and control the Tacx trainer. So, all other bluetooth connections have to be turned off – including the laptop bluetooth connection to the Tacx trainer. Here’s the steps:

  1. Delete the Tacx profile from your list of bluetooth devices from the laptop or tablet you are running Zwift on.
  2. If you are running the Tacx Utitlity, Tacx Training, or Zwift Companion app on another device (like your phone or IPAD), terminate the app(s). You can still run the Zwift Companion later but you must turn off Bluetooth on that device.
  3. Terminate the Zwift app on your laptop or tablet.
  4. Disconnect the Tacx for 30 secs and power it back on.
  5. Restart Zwift.


Many thanks for this Scott.

I worked after that my Flux needed 2 updates.

All sorted now.

Thanks again for your time!