Zwift app pair to Tacx Flux 2, but rider not moving


I’ve found a lot of similar topics about this issue, but unfortunately I didn’t find any solution. I’ve subscribed to Zwift 2 monts ago (with monthly payments), and everything went well. But today the rider is not moving anymore. I have no problem with the Bluetooth connection and pairing my Tacx Flux 2 device.

How can I solve this?

If you go to the pairing screen and pedal, can you see watts being produced, or does it say 0 watts? Can you post a screenshot of your pairing screen?


it shows 0 watts. See screenshot in attachment.

So that’s when you’re pedalling? Do you feel any resistance?

Could be a trainer problem. What happens when you try and use the Tacx app to calibrate it - does that work?

What device are you running Zwift on?

just to rule out a silly question - you were pedaling when you took this weren’t you?

if you leave it on this screen does it say no connection at all?


Yes, when i’m pedalling it stays on 0 watts. When I run the Tacx app, I can calibrate it without problems. So the Tacx app is responding to my trainer. I tried running zwift on my iPad (which i’m always using), also tries on my iPhone, with the same result.

It seem like your phone or another app is still linked to the trainer therefore Zwift can’t communicate with it.

I don’t think that is the case as it wouldn’t pair at all in that case. It wouldn’t even show up in the list.

Hello guys,

I removed zwift app from all my devices and installed it back on my iPad. And it’s working again! Thank you so much for your feedback!


Is your blue Bluetooth light showing before you even open up the Zwift App?