Can't pair Zwift to my TACX Fluid via Bluetooth right now. What gives?


(Tucker Walsh) #1

hi, worked fine last winter for me, and did my first indoor ride the other day and it was fine, but now Zwift won’t pair to my TACX Fluid smart trainer via Bluetooth. on the “paired devices” screen, when i click on one of the icons to pair it, it just hangs up and says “searching” and never finds it.

I’ve done all the usual stuff, turned Bluetooth on and off, made sure it’s not paired to anything else, rebooted phone, rebooted trainer, tried to “wake it up” by turning cranks, made sure firmware is updated on the TACX utility, etc etc. What am i forgetting/missing? Thanks


(Philip Lee) #2

Have you checked that your batteries haven’t gone flat? I had an issue with my power meter which appeared to pair ok but didn’t register any watts when turning the cranks - turned out the battery on the power meter had gone flat


(Tucker Walsh) #3

thanks for the reply. Hmm, not sure what you mean. I don’t have a power meter on my bike crank. the power numbers and ride feel i get are purely from the smart trainer/Zwift combo.