pedaling but not moving


I ve been using my new tacx flux for the past month without too many issues besides for the occassional moment when the virtual rider stops cycling even though I am still pedalling. Yesterday I updated the software and calibrated the flux but when I get to the screen to start a ride, i start pedalling but the vrtual cyclist doesnt start moving. Any suggestions? 

The most likely culprit is too many dropouts with the ant+ connection. You can check this by running your log file through zwiftalizer ( - scroll to the bottom and it shows you how many disconnects there are.

I ended up putting my ant+ dongle in a usb hub and moving it to within a couple of feet of my trainer to fix a similar issue.

Having said that, I’m assuming you’re using a pc, so if this doesn’t help, it might be worth posting some details of your setup.

I have exactly the same thing with my Tacx flux on Bluetooth. I rode using same device (Iphone X) with my HR monitor, Tacx Flux, and Bluetooth Speaker for music on 6th Jan did the update on 7th and haven’t been able to ride since. Never had a problem before that update.

New update today which I have just uploaded, will update the result on here later.

I have the same. Just did a Zwift update on my laptop. It can see my trainer heart rate etc but only heart rate shows data. Any updates from anyone?

I played about today but this was for my IOS iPhone X
Loaded the Tacx utility App and tried to update, got to 50% and froze, switched off on again and tried again no luck. Turned phone to airplane mode left wifi and Bluetooth on and tried the software update again and it worked. Then calibrated and opened Zwift shut Tacx Utility and hey presto I was back on. Make sure your flux has a green flashing light at all times. If not there is a comms error. The update that failed looked as though it had updated on the app but it hadn’t. There was no serial id for the Tacx showing.

Good luck, I’m a happy man again.

I still believe this was caused by the Zwift update locking out the Bluetooth comms port

Thanks for sharing your findings Gary. Sounds similar to my issue except I use Ant+. I’ll try tomorrow & post my findings. This beats waiting 3 weeks for Zwift to reply (not good for training!).
Great work Gary.