Ride-on option gone? [SOLVED] [Game v.1.12.1]


Since the last update and I have done 2 training sessions. I open Zwift on my PC screen while I use the companion for giving ride-ons in the easy parts of a training or when chasing a pacer.

The last 2 sessions the little white circle (counter) to show when I can give Ride-on’s in the companion map appeared in my first session after 50+ minutes (in the end) and in the 60-minute session this morning, not at all. What happened to it?

I am getting ride-on’s from others (much less then usual) so it must still be possible…

what happened? How do I fix it?

I rode Road To Sky yesterday, and the Ride On circle showed up somewhere between turn 21 and 20. The whole time in the Jungle it wasn’t there.

1 Like

Ok so I am not the only one.

I had the same issue today, no circle just the arrow.

1 Like

Update your Companion app?

v3.25 was released 4d ago.

1 Like

Absolutely!! :slight_smile:

Next ride I will check if I am zoomed in/out… then it is also gone

(would explain why it popped up during the training and why it was gone the next one)

It seems to be missing periodically on my ZCA on IOS. A forced close of the app and open again fixes the issue for me.



I’ve the same issue for a couple of rides now. In TOW, but also when I just go straight into a map/route without event or workout.
Zoom in/out didn’t help as far as I remember, same for reset/restart/etc… Only one time after a TOW-stage, the circle pop-up right after finishing.
Besides this, my companion app is struggling to keep connected and stay on dashboard/map. It’s up-to-date, nothing changed in my set-up, every bluetooth turned off, reboots done, re-installs done… not helping.

1 Like

The circle has never been active during events.


Made a little edit, probably wasn’t clear it’s not just events.


In free riding I’ve been finding the same thing. The only pattern I think i have seen is that if I do a manual ride on in the game itself, then the white ring around my arrow finally appears in companion. Otherwise it is off for the whole ride.

1 Like

I had the same issue this morning. I was doing a free ride and the white circle wasn’t there.

1 Like

Glad to see I am not crazy!! :slight_smile:

I asked during cycling if anyone had this, but no one responded.

I can confirm that in the Windows version if you manually give some one a ride on in the game, the white ring will appear around your arrow in Companion. After that the ring seems to function as normal.

1 Like

Having the same issue during my last 5-6 rides.

The Ride On circle worked without issues from when I started using Zwift (~Feb 1) until about last Friday. The first time the circle wasn’t available, I attempted force closing ZCA and restarting. That didn’t solve it immediately. I then shutdown Zwift (iPad), ZCA, Stages-Link (iPhone) and restarted with Stages-Link first, Zwift 2nd, ZCA third. That didn’t immediately fix things, but about 45 minutes or so into my ride, the circle reappeared.

I had a similar “no circle initially, circle showed up at the end of the ride” experience my next ride. The last 3-4 rides I’ve not been able to get the circle to show up.

It’s my preferred GUI for giving Ride Ons as I’m usually too gassed/shaky to successfully select a rider and click the ride on button. :smile:

1 Like

Ride on bomb circle disappeared about I week ago. I am going to update Zwift Companion

1 Like

AppleTV users have to use the Companion App to give RideOns.

1 Like

I have an updated companion but that doesn’t make a difference.

Ok, the workaround is to give the first ride-on via the windows interface (I assume you mean the list on the right side). I will give that a try.

Yesterday I did a Zwift academy training and it was not there. So I didn’t pay any attention anymore to it. I did notice however that when I was finished… it appeared on my companion. I also see that mentioned before… like you can only give it when riding free? Anyone confirm that?

I have submitted a technical request via the website btw. Let’s see what Zwift says.

1 Like