Resistance is not changing in Zwift using Wahoo Kickr 2016


(Kristian RCC AMS 0304) #1

Dear All,

 

I’ve just starting to use the Wahoo Kickr2016 and Zwift. I realise that the resistance isn’t changing when going uphill or downhill, I need to run at higher cadence to increase the power, guess this is not the way it should work, since it is not giving the real ride feel.

Any one?

 

Thanks!


(Kristian RCC AMS 0304) #2

PS. Using Macbook Pro, and Bluetooth 40 for controlling this Kickr2016


(Jason K) #3

It looks like you’ve got two different selections paired under power and controllable trainer: KICKR model 1 is under Power and Wahoo FE-C is under controllable trainer. Whichever one is under Power should also be the one you pick for Controllable Trainer, so try switching those.

If you’re not seeing a difference after switching those, you may also want to check your resistance under the Settings menu. If it’s turned all the way down to the left, it’s not going to change.

Try those out, and see if it makes a difference. EDIT: See my other comment in your other thread.


(Alejandro Martinez) #4

I am having the same issue with the similar set up.    2015 Macbook Pro and BLE to control the kickr.  I can see the power from the Kickr but the resistance doesn’t change.  I tried all suggested steps in the troubleshooting with no luck.  The other post referenced above says is an issue with zwift and the latest kickr firmware.  Just received the new kickr 3 days ago so I don’t have yet experience with other apps other than the wahoo fitness app and no issues there.  Any suggestions how to solve this?  Thanks


(Chuck Rodent) #5

I have never been able to get Zwift to change Kickr resistance when paired through BLE, whereas the Kickr will respond to other apps when paired through BLE to my iPad Pro or Mac. My only solution is to pair through ANT+ FE-C for Zwift which works fine. I’m on a 2016 Kickr with latest firmware, iMac, and OSX El Capitan. Since I have the ANT+ dongle anyway, I have not pursued this issue.


(Alejandro Martinez) #6

Thanks Chuck. Over the weekend I was able to connect my new Kickr to Trainneroad and Fulgaz with no issue via BLE.  For a second thought I had a defective Kickr!  but it looks like Zwift is having currently a problem with the Kickr control over BLE.  I am new to this, so I don’t have yet the ANT+ dongle to try Zwift.


(Roos Visscher) #7

Hi Jason,

 

I’m having the same issue with Wahoo KICKR and a macbook pro via built-in bluetooth…

What to do?


(Jonathan Large) #8

Hi Jason,

Same problem here - Wahoo Kickr 2016, Macbook, BLE 4. Erg fine with Wahoo App but does nothing in Zwift. Works fine with erg switched off but I was expecting the functionality of Erg. Just bought the Kickr and thought it was broken until I read this post. The problem seems to be at your end?

Thanks.


(Alejandro Martinez) #9

I was having this issue and with the help of Zwift was able to solve it yesterday.  Native BLE in Macs seems to be having a problem currently to control the new Kickr, so a work around is to use the iphone mobile app (Zwift Mobile Link - ZML) as a bridge for the BLE sensors including the kickr.  Open the ZML in the iphone, and make sure that under settings, sensors, Bluetooth BLE is enabled.  Make sure the iphone is in the same wifi network as the Mac.  In the Mac, open Zwift and in the pairing screen unpair all sesnsors.  Just in case sensors are already connected to the Mac via native BLE.  BLE sensors can only pair to one device.  In this case, we want them to connect to the the iphone which will bridge to the Mac. Then in the upper right of the pairing screen in zwift select the settings gear and select using Zwift Mobile Link.  Pair again all sensors and the Kickr.  This worked for me and my new kickr is now changing resistance.


(Jason K) #10

Just to confirm what Alejandro has mentioned: there’s an issue with resistance control not working over native BLE with KICKR. Instructions for working around this by connecting BLE via the mobile app are on the knowledge base. We’re working on a fix now, and it should be in game soon.

Thanks for your patience all!

 


(Mark Fitzgerald) #11

Any sign of a fix, its driving me crazy as I cannot not get the work around to work either…


(Robert Allen (D)) #12

I am not able to get the system to work and I cannot get the mobile app workaround either. 


(Margaret Oliver) #13

I have a Kickr2016, Macbook OSX Sierra, tried everything I could think of to get the resistance to change, searched all over. Tried the workaround using the mobile app, which didn’t work for me, but between multiple apps running and BLE connections I may have not done it correctly. 

Anyway - my Kickr and cadence were connected via BLE, but I have an ANT+ dongle for my Garmin. Unpaired the Kicker and cadence and re-paired using ANT+, and it works now. Can see the slope change reflected in the Wahoo app (in sim mode) as well as feel the difference. Basically restored my sanity using ANT+ connections. 

 

 

 


(Jason K) #14

Good news! The latest update should have solved this issue. Please submit a support ticket if it’s still occurring for you, as it’s more likely to be setup/account specific. Thanks!