Queen's Highway Route Achievement Bug/Error

Hi, today I set my route to 3km Queen’s Highway, apparently it leads me to UCI 13.2km route and yet I was not awarded Queen’s Highway route achievement. Anyone come across similar error?

This route?
https://zwiftinsider.com/queens-highway/

Check if you got the segment on strava

https://www.strava.com/segments/21748231

1 Like

Hi Ben,

Thanks for your reply. Yes, thats should be Queen’s Highway route that I preview when I choose and select the route. I have double checked the route name before hit the “Ride” button.

My ride turn up to like this in Strava … UCI 13.2km route.
https://www.strava.com/activities/3364046077

I did another route 3km Duchy Estate, there’s no problem, the actual distance is
5.32km instead of 3km, but I am OK with that as I get the route badge.

To get the badge I believe (from what I’ve read) you need to do the “lead in”. So if you riding and just decide to do a route during the ride you will have missed the proper start (the lead in) of the route. If you check the strava segment I posted you will probably won’t be on the leaderboard anywhere because that segment includes the lead in.

This is also why the 3 km route was longer, the extra length was the lead in.

You see this in races sometimes, the race is 3 laps of a 10 km route say, but the race is actually 33 km long because of a lead in.

Hi Ben,
I got your point… then since Queen’s Highway is a loop, should i wait for this “lead in” nearby me then I join them? Is the “lead in” shown as many white dots (zwifters) at the top right elevation profile?

Something still puzzle me why my previous Queen’s Highway (smaller loop) lead me to UCI route (larger loop), it is totally different route course, that’s why I am reporting this bug or error.

My understanding is if you select the correct route from the start menu of zwift (before you start riding) then it gives you the lead in (this is an extra distance at the start not extra people) which leads you to a loop. After the route is complete (depending on the route) either it will continue doing loops (e.g. volcano circuit) or it will send you to a different route (I guess yours is an example of this). That’s my understanding anyway.

Ok sorry. My mistake. There seems to be a bug. I understand you now. I just jumped on and clicked the route and it started me with doing a U turn and took me the wrong way.

And the second attempt it didn’t throw a u turn but I didn’t finish the loop just did 10 m.

1 Like

No worries Ben. Hope to get more votes so Zwift team can look into this glitch. Also thanks for verifying the error.

Just did it 29 April 2020. Badge awarded at 5.6km, Queen’s highway selected at start menu.

I would try it again since Zwift release updated firmware. Thanks for your reply.

I’ve had this problem today, using the app on Android.
I chose Queen’s Highway and it set me off on the UCI World’s route. I ended the ride and tried again but it did the same.
I did a U turn and rode the route manually but it didn’t pick it up as Queen’s Highway even though I rode the lead in (plus a bit) then 3 laps of the loop.
I’ve just opened the app again now after a forced close, and tried it again and it seems to have put me on the right route, so it looks like it’s an intermittent issue.

1 Like

Where you using a MacBook?