Problems with Elite Turno

trainer
companion
(Pedro Martinez) #1

Hi guys,

I’m having problems with Elite Turno and Zwift. First riding power and speed was too high. I did a reset to Elite Turno and then, power and speed was too low… Frustrated.

Is there any information to set up Elite Turno and Zwift correctly?

I also did set up with MyEtraining and, it works perfectly with The Sufferfest.

Many thanks,
Pedro

(Joe) #2

I can’t find any references to the Turno being a supported trainer w/ Zwift. I know Elite says it can work, but nothing as far as I can see in the supported trainers list or here: https://support.zwift.com/de/-ryokRkWrm

How are you connecting your trainer? ANT+ or Bluetooth? What is displayed under Power Source on the pairing screen? How do you know your power is too high or too low?

(Pedro Martinez) #3

Many thanks Joe,

Elite’s web shows the information about compatibility https://www.elite-it.com/en/products/home-trainers/smart-trainers/turno

I am connecting trainer through Bluetooth as I am using Zwift from my iPhone X. I know that power (up to 3000) and speed (70 km/h) is too high for my effort and, moreover, Zwift prompts a message saying that I should calibrate my trainer.

Thanks

(Paul) #4

Have you checked out this link: https://support.zwift.com/-setting-up-an-elite-turbo-muin-Hyh1AyZrX

I believe your trainer has the Misuro B+ sensor in it.

(Pedro Martinez) #5

Thanks Paul, you’re right, Elite Turno works with the Misuro B+ sensor.

I followed instructions that came with trainer to set up (assume newer instructions as Turno needs 15 blinks when you set up the sensor).

What I don’t understand is if I need to do something different in the MyETraining Elite App. Here I have options with the wheel diameter (I can’t upload picture to show you instructions right now but I’ll be able tomorrow).

Quite frustrated, as compare with The Sufferfest, you can set up from the App and pick “Elite Turno” or “wheel diameter” and works fine. Zwift connects directly with the trainer so I don’t have options to adjust.

Any clue?

Thanks :pray:

(Joe) #6

For Zwift, the wheel circumference setting in the MyETraining app has no impact whatsoever unless you are using speed data transmitted from your trainer and pairing the Turno as a ‘classic trainer’ w/ speed & cadence sensors. Then? You have to use whatever weird ‘virtual’ wheel circumference Elite recommends.

(I just looked it up for the Turno, and it’s your real wheel circumference / 15.34), or ~2105/15.34 = 137.2 mm for a 700c x 25mm tire.)

But… you shouldn’t do this! Because, if you do, then you aren’t using the power data from your trainer to determine your in-Zwift speed. You’re using some approximation of your imaginary rear wheel’s “speed” to arrive at a Zwift-calculated power value in Watts that may (or more likely may not) be a reflection of your actual power output. This is because Zwift is treating your trainer like any ‘dumb’ trainer and applying your speed data to a power curve, and spitting out a power number. If the power curve used is different from your trainer’s actual curve, there’s no hope for accuracy! (e.g. 3000 W :rofl:)

What you want to do is be sure that you are transmitting POWER data from your trainer to Zwift. You do this by pairing your trainer (or the Misuro B+) as a Power Source - not a speed sensor.

Your in-game speed will then be determined by your power and your weight (in your Zwift profile).

Good luck!

1 Like
(Pedro Martinez) #7

Thanks Joe, problem solved. I followed your recommendation and it works! FTP test done!

Many thanks

1 Like
(Joe) #8

Happy I could help.

Ride on! :+1:t2: