Problems entering races

Recently I have had multiple instances of the following:
Sign up for a race on Zwift Companion on iphone
Get onto Zwift and start warming up in some world or other (30 minutes before event)
No (Join now) ever appears and the event starts without me.

Today I was due to do a TT, I couldn’t get in prior to my start time, then restarted both my Zwift and my Companion, nothing.

I run Zwift on a laptop (MS Surface).

Any ideas? Keeps happening

Hi @Ian_Jackson, welcome to the forums.

Give us a run down of your equipment, devices you use for Zwift (especially if you use more than one ipad and iphone for example), trainer, sensors, zwift companion app, connection protocol, etc. The more detail the better.

The first thing to do is make sure everything is updated to the latest version of Zwift.

1 Like

Hi @Ian_Jackson

Do you sign up before opening Zwift? If you do it while in the world selection screen the Join now button does not appear.
You have to do it before opening Zwift or while your are already riding.
Also make sure you see the Map on the companion app (ZCA) while riding.

iphone x for Zwift companion
Trainer is Tacx Neo 2, fully up to date

Also Garmin HR sensor

PC is Surface Pro - only allows you to run on most recent version. I know all my software is always up to date. I am ■■■■ with that stuff.

I connect them all using the Bluetooth only, not my ANT Dongle

I sign up well before opening Zwift - normally an hour or so before as I plan when I will ride.

I have tried entering a second event when in Zwift after the first one wont let me in, getting same issue.

I know there are challenges with ZCA if not on same network, I always make sure on same wifi.

Hi, I’m having the same issue . I 'm new to Zwift .I can do workouts but can’t join group events.I’m using a Tacx Flux and Windows 10 on a PC.

Hi @callum_hendry

Welcome to the forum.

How do you sign up for the event.

Do you see the Join event button while warming up?

Hello Gerrie,

I do not see the “join now” invite. I have tried to join group events using an updating list of events visable on the top right hand side of the screen. When I select an event a red tab appears which reads"going", but nothing more happens. I am not then invited to confirm my entry nor am I taken automatically to a start line.

My recollection is that I haven’t fared any better when trying to enter events using Zwift Companion. However I can access the workout sessions.

Thanks, Callum.

You need to be riding in any of the available worlds to get the “join now” button, it will not work from the route selection screen.

1 Like

Hello Mike . Many thanks for taking the trouble to reply to my plea for help. I did as you said and it worked. Hooray ! It’s helpful to have that clear and to have learned some of the terminology ,e.g. " the route selection screen ". I suspect that I had done exactly that before . I wondered if the reason it worked this time was that I have disconnected an old , now redundant, wheel- on type trainer from the system and so cleared up some confusion ? Dunno . But many thanks.

1 Like