Not getting a "Join the race" message

After registerring to an event, either by the “companion” or by the Desktop application. I do not get the “Join the race” blue message.
is it something you experianced?
really frustrating

Thanks

Hi @LIOR_SHERER welcome to Zwift forum.

Shuji at ZwiftHQ here. First - I see you’re running Zwift Companion v3.11.0 on iOS v9.x.
Please update Zwift Companion to v3.11.1. This is a patch specifically to fix some incompatibility issues on iOS 9 and 10. Please update and let us know if this resolved your issue?

As long as we’re talking about it, ZC v.4.x will be coming in the foreseeable future, and it will not run on iOS versions 10 and older. You can continue using v 3.x, but will not be able to use features that require v4.x. Be advised.

thank you for the prompt reply
but as i wrote - it doesnlt work even when i register directly on the desktop app, regardless of the ZC

Hi @LIOR_SHERER

After you register for a event using the companion app , do you start zwift and start riding waiting for the join event to pop up?

Things to remember,

don’t register wile on the world selection screen, that can confuse zwift a bit, do it before opening Zwift or while riding.

See this video.

Hi and thanks
I was doing everything right.
Actually i was able to join a race 2 days ago.
unfortunatly, that was the first and only time this worked. i did everithing the same way - but it doesn’t wark.

Are you starting a ride and spawning into Watopia or the guest world of the day at least a few minutes before the start of the event? You will not see the “join now” button unless you are in a ride, you can’t join from the world selection screen or pairing screen, etc.

thank you
Yes i’m “waiting” while riding …

You wouldn’t happen to have multiple accounts on Zwift, maybe a free child account? Wondering if you are signing up for the event under the wrong account?

I have had this happen, not exactly sure why but if I’m waiting for the event to start and I don’t see the invitation I’ll use the companion app to unsign from the event then resign right back and that fixes it every time

I suspect it has something to do with me having 2 different wifi networks but I’m pretty far from an expert

BINGO
thank you - that was it
once i had them both working, and on the same WiFi - it worked.
Does that mean that i always must have the ZC and the dasktop running together?

2 Likes

@LIOR_SHERER
Glad to hear you’re squared away!

You don’t have to have Zwift Companion running, but it enhances the things you can do in the game app.

Some actions can be done with either app (taking a snapshot, making a U-turn, etc). But other things can only be done via Zwift Companion. We have a guide to the things you can on our support hub.