Can't 'Join Race'

Hi All,

I have been having an issue where I am not invited to ‘join race’, I am also not automatically put on the start line, I am put into Wattopia and simply ride around. If I join a group workout I do not have this issue it seems to be specific to races. Races are why I signed up to Zwift so this is annoying. A few weeks ago I was able to join races, and I have not changed a thing.

I have a windows laptop and downloaded Zwift for windows, and I use a Wattbike, again no issues until recently.

I have tried a few things I’ve seen on here like joining on companion first etc. none of these things work.

My laptop is a couple of years old and a good spec, I don’t think its a hardware issue.

Is anyone having the same issue as me or am I the unlucky one?



Hi Tom,

Are you using the new home screen or the new one?

If the new, once you have signed up to an event you should be able to choose to enter it from the home screen (if within 30 minutes of start time).

If old home screen (and also new), you should get a join event notification pop up when you are in game if within 30 minutes of the event starting.

I may be telling you how to suck eggs but also wanted to double check.


James, thanks for the message.

This is my issue these boxes are not popping up.



Thanks Tom,

How are you “joining” them? Companion App or through the game or website?

I downloaded the game on a Windows laptop, I opening the game, select an event race. It then says start ride below, so i click on that. It takes me into the location but does not say join race on the bottom left of the screen, nor does it take me directly to the startline.

like it say it has worked for me before using these methods but now it does not.



Can you try using the Companion App to sign up for your events and see if this fixes the issue for you?

Both me and partner tried this but it didnt work for either of us. Could there be a bug with the windows game?

I wouldn’t think so. I run Zwift on Windows myself and have only encountered this issue extremely rarely - restarting the game fixed it for me.

It probably wouldn’t hurt to reinstall the game to see if it remedies the issue.

If the join event prompt isn’t present when it should be, leaving and signing up again (via the Companion app) typically makes it appear for me. It’s rare that I need to do this though.

This may be a very stupid comment but sometimes overlooked so I will be the one to ask this. Did you check your windows PC Time and date that it is set correctly?

I have tried everything mentioned in the posts but still no success.

un install, reinstall, companion app unjoin and re-join. Time is BST auto updates on the laptop. but still the same. I literally tried all usual troubleshooting. Its crazy!

Ive been trying again, have a look at the screen shots ive taken. I select the C group then it says start ride. I select start ride and i takes me into the game, when in the game i get no option to join event/race.

thanks for all your time and help btw.



Did you see any other riders in that world while waiting. It does look like you are the only rider in that world.

Also, don’t use the companion app to select a ride while in the pairing or Home screen, do it before opening Zwift. You can select a event from the companion app while riding, that does work.

Good point I do appear to be the only rider in the world. I have just gone into a free ride and the same issue, i am on my own. Do you know why that would be happening?

That is usually a network issue. Try to restart your router.

Just restarted the router. Still no change.

Are you sure you’re actually connecting to the internet? No other riders is generally a condition of not being connected to the internet.

Is it a work laptop? Could be a VPN or firewall settings that are stopping it working properly.


Steve you have solved the issue. Its not a work laptop but Mcafee did recently update and installed a VPN. I just disabled it and it now works!!!

no more lonely rides. Thanks :slight_smile:


This genuinely makes me happy :slight_smile:

Have fun Thomas!

1 Like