Problem with Tacx flow and ant+ and BLE

Hi, I have the following issue
I connect the tacx flow roller, with macbook pro (ios high sierra) and ant +, but the signal falls a lot, during the first hour the signal varies too much, after the training hour the signal remains constant, I attach images. with BLE the same thing happens, already update the roller, calibrated, turn off other BLE and airtv signals. what could happen? regards

I have a new tacx vortex connecting via ant+ to my laptop!

1 Like


If you can take the trainer to a friends house and reproduce it there, then it would suggest that there is something wrong with your trainer. If it stays connected then there must be some interference at your home.

If you try zwift on your phone (or other device) and it stays connected then maybe it’s your laptop.

1 Like

@David_Ramos_Rivera - I have the exact same issue with my Tacx Genius Smart, Macbook Pro (ios Mojave) and ANT+. I thought High Sierra was to blame, so I upgraded to Mojave but the issue persists. During the first 30 min for me it is impossible to ride as the speed/cadence/resistance/watts are all over the place or signal is dropped. The slope will be 5% in the game, but the trainer is speeding up with decreasing resistance, and connection is dropping frequently. It finally stabilizes after some time or after rebooting and repairing 10 times, but I cannot figure out the cause. I have the ANT+ extension cable connected and within 1 foot of the trainer, updated firmware, got rid of fans/bluetooth and other interference, all to no avail. This issue only started recently when i moved to a new home, but I can’t rule out a recent software update either.

Hi @Kate_M

Welcome to the forum.

You can drop your log file in to and look for ANT+ dropouts.
Do you pair as ANT+ FE-C.

It can be that your WIFI router is closer to your training setup than in the old house.

Yes, paired as ANT+ as BT no longer shows as an option in the pairing screen. I have a wifi repeater about 6 ft away from the trainer, but the channel is set to 2. Could this still be causing interference? Unfortunately, without the repeater there is no wifi signal in this area :frowning:

Not sure what to make of the results from Zwiftalizer:

hello everybody, thanks for help.

I found other solutions, I open Zwift from pc and configured the route and training from training peaks, next I open Bye signal from phone, and connect the tacx roller and open app Zwift companion, this app connect with Zwift of pc and send a signal to pc and can ride.

the picture show the right connection.

the problem is on my house, the signal from smart tv, BLE from other phones and google home mini, I can’t turn off this signals every time I use the roller.


Is there a log file for one of the rides that the trainer was acting up and you restarted it? Or is this one of those log files?

Have you turned off the trainer recently or do you leave it on?

Is the trainer still connected to its own tacx app?

And also, why isn’t bluetooth an option? Did it used to be?

The photo above is from one of the rides where the ANT+ connection dropped frequently, but not the worst case I’ve experienced. Photo below is a test ride today when I moved the TACX Ant+ as close as possible to the trainer.

I always turn off and unplug the trainer after I’m done riding.

I don’t use the TACX app regularly. Used it to check firmware and calibrate a few months ago.

Bluetooth stopped showing up recently as an option to pair. When it does show up, the connection bars are so low that it flashes “NO SIGNAL” when you try to use it. I think that my recent purchases of a few bluetooth and wifi accessories that are in the same room as the bike are to blame. Compared to before when it worked properly, these are the only new additions.

Just in case it’s the Tacx ANT+ failing, I purchased a new ANT+ connection and extender to try. Also am going to try to pair via the Zwift companion and use Bluetooth, but I did this in the past and it wasn’t a very stable connection either.

Are you using your trainer in hot conditions? Maybe this is nothing to do with it, but Tacx Flow trainers seem very prone to overheating problems (which lead to signal dropouts).


Update: Issue seemed to be with the Tacx ANT+ dongle, as I replaced it with “CooSpo ANT+ USB Stick Dongle with Extension USB 2.0 Cable 6.56Ft” and haven’t had the same issues yet. Bluetooth now shows up as an option to pair and am able to use it with Zwift Companion again.