Ant+ Dropping since last update (Jan 2020)

Oh wise ones, you council is much needed please…

Firstly, I’ve has no problems whatsoever, until the last update.

My Ant+ connection drops after about 10 seconds (Power Meter and Smart Trainer.). I pair with Ant+, then it just drops the connection completely. Just doesn’t show. Unplug dongle, and try again, it just doesn’t show but on the initial startup of Zwift it does.

Bluetooth connectivity is absolutely fine.

Macbook Pro (2017) and have also tried Macbook Pro (2020) with the exact same results. I’'ve also tried two different Ant+ dongles (Tacx & Garmin) both on the different laptops, again exact same result.

Tacx Flux S - latest firmware
Powered USB 3.0 Hub
Active USB 3.0 Cable
Ant+ Dongle located right next to Tacx Flux S (running latest firmware)
WiFi Connectivity is via 5Ghz (2.5Ghz is running on Channel 1, but irrelevant as I use the 5)
No Fans in the same room (have removed to testing purposes)
Protected HTML cable, so no leakages from the USB or HDMI cables
No other software running on laptops that maybe grabbing the Ant connection (Movescount or Garmin)

As I said, nothing has changed other than the lastest Zwift update.

Any advice here please, I’m not sure what else to check?

Did you use the extension cable both times, or have you ruled that out as a possible culprit? Also try other USB ports on the laptops?

My ANT connection has been fine, but I use Windows 10.

Heard a few people mention this now. I’m under 0.5% rxfails, so I’ll be able to tell next time I ride if anything’s changed.

I’m using a USB-C powered hub with a USB 3.0 Active cable. I have also tried with the Ant+ dongle directly in the HUB, the same result both times (direct in the hub and via active cable).

That would be great Dave is you could please report back. As I said, running this setup without any problems until the last update.

have you put a log file into www.zwiftalizer.com to see if you are getting a bad ANT signal?

I have never been able to get ANT+ to work through a hub. I’ve always had to plug the dongle or the cable directly into the computer.

Hi Mark, I’ve not had an issue with this setup in over 1 year. I have tried the dongle direct to the laptop via USB-C connector (Mac’s dont have USB ports) as part my testing. Although I will try this again to 100% rule it out.

1 Like

Hi Mike, I have uploaded the log.txt although I’m not sure what I’m meant to be looking at? Any pointers?

when you drop a log file into zwiftalizer you should get a report, it will have your system info at the top and then graphs for frame rate, network quality, ant or bluetooth signal quality, etc…

Thanks again Mike, the log I was analyzing didn’t have an Ant+ section. I looked at one from last night which did… it reported … "

Yikes! Your ANT+ device signal was up and down like a fiddler’s elbow. Your environment is the most likely cause. Work through the recommendations below changing one thing at a time."

All the advice in the report I have already done, except for one which is about the 2.5Ghz WiFi Channel setting. I don’t use the 2.5 Wifi but will change the Channel setting anyway. I’ll report back…

1 Like

2.4GHz… (?)

Shut it down while Zwifting, unless you absolutely have to have it, it which case make sure it uses the higher channels.

*lower channels

1 Like

ANT+ uses 2457MHz. This collides WiFi’s 2.4GHz channel 10. But due to WiFi channels width, anything between 8-12 (inclusive) should be avoided (Edit: ANT+ packets carry primitive checksum info… this should lower error rate even if channels overlap …)

So, basically, yes… :slight_smile:


1 Like

It’s not made any difference. 2.5Wifi now on Channel 1 (it doesn’t get used anyway).

Active USB 3.0 Cable
Powered HUB
Protected HTML cable
Tried 2 different Ant+ dongles
Changes the 2.5 Wifi channel to 1
Happily running for over a year until last update

Any other ideas chaps?

Will try this next… switch off 2.5. I installed a WiFi scanner see what’s happening. That channel 11 is picking up load of neighbours stuff, so now wondering if the problem lies there.

Hi Lads, okay, just to close this one out… It appears it was a problem with my USB 3.0 active cable. The Ant+ dongle was a little ‘loose’ when inserted. I got a better quality cable (with a gold plated connector) and the Ant+ dongle is now a ‘firm’ fit… and so far so good I’ve not had a dropout yet. Took a while to get to this point, but looks like I’m there.

Thank you all for taking the time to reply.

3 Likes

Great to see someone methodically troubleshooting AND feeding back the result. Helpful for anyone else lurking.

3 Likes