Problem hitting wattage during a workout


I have a Kickr V5 connected to an iPad as the main screen and I also use the companion app on an Android phone.
I have been using the smart trainer and Zwift for about 8 weeks. It is my first smart trainer.
Today, I tried doing my first workout in Zwift and ran into the following issues:

  1. During warm up my wattage is always about 5-10W below the target on the screen, e.g. if it says pedal at 90W, I cannot get above 80W or 85W. It doesn’t matter how fast I pedal. The resistance does increase, however, it is impossible to reach the wattage required on the screen.
  2. Once the warm up is completed, the app tells me to hit e.g. 170W, however, the resistance on the trainer gets very low. It doesn’t matter how fast I pedal, it would not be higher than 110W.

I have tried several things, including staying in the same gear, doing another workout and changing gears. I have also updated the firmware in the Wahoo app. Additionally, I tried performing several spin downs in the Zwift app, but the screen gets stuck at continue pedalling at 37kph. It seems to be impossible to do a spin down/calibration.

Sorry if this has been posted before, I could not find an answer in the forums.

Any ideas what I’m doing wrong?


Hi there. My new kickr V5 (it arrived 2 weeks ago) needed a firmware update. Maybe that causes the difference. Also make sure to enable erg smoothing (or however it’s called :slight_smile: )

Hi @DarkFall01, welcome to the forums!

Don’t use Zwift for spindowns, and I think the Kickr V5 doesn’t need to do calibrations anymore. Isn’t that one of the new features of the Kickr V5?

Check the settings with the wahoo app, as Anthro mentioned, make sure ERG smoothing is enabled.

1 Like

Hi, thank you both for your replies.

“ERG Mode Speed Simulation” and “ERG Mode Power Smoothing” have been on in the Wahoo App. However, the app is not open when I run Zwift. Should it be open?

You are correct about the calibration, it is no longer required.

Any other ideas on how to get this fixed?

Double check that your wahoo app isn’t stealing the signal from the trainer when Zwift is in use, pair it as power and controllable, turn other bluetooth devices off incase of signal interference.

1 Like

The wahoo app doesn’t need to be open during zwift. But maybe you can try a workout with the wahoo app and see if you reach the watts there.