Power seems way too low for the effort


(Charles ROL Racing) #1

Wahoo Kickr Snap, brand new, first ride today. I did the spindown calibration after 15 minute warmup. Then went on a flat ride. I was working hard to maintain 150 watts which seems very low. Don’t feel any slipping of the tire it just seems like the speed lags behind what I am doing and the power is down from what it should be.


(Joshua Downing) #2

The same thing for my friend when he uses cyclops smart trainer. He works his butt off and hardly reaches 200 watts. I have a traditional trainer and uses my ble device to hook up. His smart trainer is ble and not any+


(Mitch Fury) #3

Same thing happens to me on the Wahoo Kickr with finishing workouts. Workouts and the like void any of the gradients that you see on the screen.

Only workable solution I have at this stage is that I exit Zwift and log back on, fixes the issue (however this is a minor inconvenience), otherwise I’m spinning like crazy and getting nowhere fast.

If you also read their latest update you can change the resistance on the app or on the computer by pressing + or -. This would also help but not the same.


(Craig Lintz) #4

I’ll 2nd that issue - work my butt off on the flats and go no where… Hills are a little better but the flats are extremely frustrating and a waste of time.

Any suggestions?   The app on my Droid phone works and looks completely different than the same apps on my wife’s iPhone.  Anyone know why?


(Craig Lintz) #5

I’ll 2nd that issue - work my butt off on the flats and go no where… Hills are a little better but the flats are extremely frustrating and a waste of time.

Any suggestions?   The app on my Droid phone works and looks completely different than the same apps on my wife’s iPhone.  Anyone know why?