Polar H7 not showing up

I want to connect my Polar H7 hartratemonitor with Zwift. I tried a lot of things without any result. My setup:

  • Tacx Vortex Smart T2180
  • Windows laptop (connected to the same wifi network as my phone)
  • Tacx ANT II USB Antenne T2028
  • Android Phone (4.4.2)
  • With the mobile link app installed and the bluetooth is on. (If I go to settings -> bluetooth it sees my Polar H7 (not linked))

I start zwift on my laptop and then open te Mobile Link app. On the pairing screen both ANT and Bluetooth signals are on (have radiowaves). It finds the Tacx Vortex almost immediately but when I search for the HR it finds nothing.

Can anyone please help me?

PS. I also tried to link my Polar H7 to my phone and then start up zwift but also then it is not working. My Polar H7 was linked to my Polar M400 watch but not anymore and is now not linked to any device.


You’re on the right track with not linking your Polar to your phone first. If it’s paired to anything else, Zwift isn’t going to see it, so you’ll want to avoid that.

Are you pairing any other Bluetooth devices through your phone at the same time? If so, unpair those since phones can only handle a few connections at a time. You may also want to apply some moisture to the HRM connectors and/or try replacing the battery if you haven’t done so recently.

If you’re still not having any luck, open a support ticket with us, and we can look into it further with you.

I’m not pairing other Bluetooth devices through my phone and I apply always some moisture to the HRM connectors. Also if I install Polar Beat I can see the battery status of the HRM is “full”  so I don’t expect the issue is related to that. (While trying linking my HRM to Zwift I always uninstall Polar Beat, so no issues there)

It looks like everything (phone, Polar Beat, and laptop) can see the HRM but Zwift can’t…

I tried the Mobile Link app with my Android Tablet (android 5.1.1) and that works! So it was not working because of my phone or android version, I suppose. But android 4.4 is supported right?