Pinnacle HC Turbo connected but no power output

Hi all, hoping for some help please!

Turbo Trainer: Pinnacle HC Turbo
Zwift app device: Windows 10 PC
Zwift version: Launcher 1.1.10, Game 1.52.0

I am able to connect my trainer to Zwift via either ANT+, or Bluetooth, pedaling on the connections screen shows no output, and during the tutorial pedaling does nothing and my avatar stays still.

My pairing screen is below.

I have tried just using either ANT+ or Bluetooth, and the results are the same.

I get the same results when connecting to the android app with desktop disconnected. Full connection via bluetooth but no output.

This is making me think it’s a defective device.

Any help would be appreciated please.

I’m not familiar with the trainer and it’s not a common one, but it looks like there is a Pinnacle HC app that can be used to do firmware updates and stuff like that. I would try connecting to the Pinnacle HC app, check for firmware, calibrate (if it does that), see if the app reads power from the trainer (if it does that). You might also try it with some other apps like TrainerRoad (do a 30 day trial just to find out if it works).

Hey, thanks for the reply.

Apologies I should have mentioned. I have the mentioned app and I’ve used it to connect my phone to the trainer, with the corresponding light on the trainer and app showing a working connection.

I’ve also used the app to update the firmware.

The app does have a Spindown Calibration feature, however this detects no rpm or power output either.

Since calibration doesn’t work, I think you need to be talking to the manufacturer or dealer. Maybe still worth a try with some other app but it’s probably faulty.

Thanks. I did a full factory reset, and tried multiple times between updating each firmware, and unfortunately no response.

I’ll initiate a return.

Thanks again for the help!