Peloton HRM "No Signal"

Not sure if related to the other known issues, but people seem to be talking about many pairing related issues. When my HRM is selected in the pairing screen, it will briefly show the battery level, or when selected briefly show either 0bpm, or the current bpm, then will display “no signal” after that and never provide heart rate.
This symptom happens on 2 Windows 10 desktop machines.
The HRM DOES work on a Windows 10 laptop, and used to work on a Macbook pro, but that machine died since.
The HRM also works with the desktops through the companion app, though I would prefer to not HAVE to do that but will for now.
The Kickr Core works fine on all configurations(mostly old phone and old macbook had issues with over companion, unrelated).

I have tried 3 or 4 different bluetooth driver versions. Disabled firewall and virus protection. Reinstalled Zwift removing the Zwift Documents folder. Installing the battery of VC redistributables. Replacing HRM batteries. Making sure no other devices are connecting to the HRM at the same time. I did not pair the HRM in windows, only Zwift.

Machine details:

  1. HRM doesn’t work
    Windows 10 version 21H1
    I5 6600k
    Nvidia 1070
    Gigabyte AC8260 PCI-E Wifi/Bluetooth 4.2 card
  2. HRM doesn’t work
    Windows 10 version 2004
    Nvidia 3090
    Intel WiFi 6 AX200 built in wireless chipset
  3. HRM works
    Windows 10 version 1703
    HP ZBook Studio G4
    AC 8265 wireless chipset

Burned hours on this, and chat support basically just said to try different drivers. They also said that “external BLE” wasn’t supported, though none of my wireless are really external, at least not USB. All are Bluetooth 4.2 or better. And the Kickr works fine.

What can we do about this?

Had similar experience. My take this is a Zwift bug (Zwift has neither confirmed nor denied this… it is, as always, silent.)

Not sure if you are up to this, but a 3rd party Windows 10 app that uses BLE HRM can be found here, and could serve as an additional diagnostic tool.

Another alternative (which you may have already tried…) is to link the BLE device via the Companion app.

Good luck!