No signal on HRM

I have a android phone system 13, zwift doesn’t fimd my HRM. It connects but then I get “no signal”. And the HR is 0. Everything works fine in my laptop. I have latest update of zwift, what could be wrong ?

You’ll need to give more detail about what device you are using to run Zwift and what HRM you are using along with how you’re connecting it.

My phone is OnePlus 8pro and my HRM is garmin HRM dual.

You can connect only 1 Bluetooth at the same time to your Garmin HRM.

Ok, but it’s not connected to the laptop or anything else at the same time

But it could actually be connected even thought you are not running an app on the notebook. It happens all the time. I had to ‘forget’ certain sensors on notebooks and other computers because they would occasionally pair with the wrong device.

Also, another issue I’ve had with the Dual is if the battery gets old, it will not attach with some devices. I think the power level of the transmitter lowers as the battery dies, and some systems just can’t see it over the other signals we swim in on a daily basis.

I’d try using a new battery, and if it still doesn’t connect reliably, drop that from your notebook and anything else that could grab it. (Try turning your notebook off and see if it drops again)

I have a new battery and everything else is turned off. Ot must be some settings in the phone itself, I don’t know what that could be. I gave android version 13

Check the phone Bluetooth settings to see if the HRM is listed there. If so, select to ‘forget’ the HRM. The HRM should be paired only through the Zwift app.

Just to finish this, I had to reset all settings on my phone to fix this. Nothing else worked. But it´s ok now :slight_smile:

I’ve had to do that with BT headphones and ear buds before. The iPhone just gets confused apparently.