Parlee speed mission

Mine didn’t either…my app is on my iPad not ATV

Same, ipad as well, updated app before riding and still sitting on zero kms after 2 rides today.

Never saw the T & C’s window btw, maybe that is glitch.

Just a shame that Zwift let’s itself down with these flaws… like the route distance issue…

1 Like

Ok, maybe I spoke to soon! Sketchy logging to Parlee mission continued today. I rode two rides back to back this morning, a solo ride (14 miles), then a group ride (10 miles). For a yet unknown reason, the 14 mile ride did NOT record to the Parlee mission, but the group ride DID. In both cases, I followed the same process for saving my session… menu/end ride/let it wait the 30 second countdown on the save button/saved/menu to close down the app/then force closed it (which seemed like it might have worked previously). One thing I can say is the Zwift app isn’t running the latest version (it’s not yet available on ATV), but this is one of the things I’d heard before when odd things crop up like this… but I can’t update if it’s not available, AND that doesn’t explain why one of two rides did record properly this morning.

I’m not ready to flame out on Zwift yet as overall I am satisfied with the app and it’s gone a long way to getting me back into the habit of exercise, but I am frustrated because I signed up for the Parlee mission to get into the running for the new bike, but the days to the 4/15 deadline keep ticking away and my rides aren’t recording. At this rate, I’ll have to ride 40 miles/session through 4/15 (and hope they record) to stay in the running.

Anyone have ANY thoughts on how to rectify this situation? I still haven’t seen a response from the support ticket I entered on 4/2 either (with the exception of the original reply I received stating they’ve received my ticket and will get back to me as soon as possible.

For me it worked one time but not the next . One day apart ,saved it the same way both times .

Where do we find our Parlee Mission miles? I can’t find it in the Companion. I can’t find it on the site. I can’t find it in ZwiftPowa. Is it hiding in the app somewhere?

Nevermind. I found it on the front page of the app. I’m a noob…and an old noob…

I don’t know if this will help but…

Have you registered with ZwiftPower? That might help. Also running the Zwift Companion on your phone might help too. I run the Zwift ride app on a laptop system over WiFi and it makes using ZC much better.

I lost two stages of the Tour of Watopia two weeks ago (yeah, that really sucked…) but haven’t had any trouble with uploads since I got on ZP and ZC. It was suggested to me when I lost the two stages. I was able to upload them manually but I didn’t get credit for them because they were just miles on the Tour route at that point.

Very frustrated. I did a mission ride three days ago, as well as a warm up before. Both registered, so I figured I was good. Did a long ride yesterday, and it didn’t register. To make it more frustrating, my wife ride with me, and hers DID! Both of us on iPad, both with companion. Both see our rides on companion. What gives?! I sent a ticket to Zwift hoping they can backfill.
I just got back into cycling on the tour of Watopia, and got really excited, but this stuff really turns me off.

My rides are also not registering. I am also on AppleTV. My Zwift is up-to-date (the Friday 3 worlds update has not dropped on ATV yet). I always quit Zwift before leaving Apple TV. I registered on April 2. I road on April 2 and April 3. Neither ride was counted.

do you force close it after every ride?

Yes, I force close all apps on the Apple TV after each ride.

Another frustrated rider here … got up early to get some miles … and … it hasn’t logged them (iPad)


I think it’s pretty obvious that Zwift likely won’t do anything about it (or if they are, it would be REALLY nice to hear about it from them as I also logged a ticket on 4/2 about the issue and also requested a backfill and have heard nothing).

At this point, 5 days into the challenge, about 50% of my rides aren’t get logged to the mission (though they all save to the web and are viewable in the companion app). I typically run on ATV and have tried all the tricks that have been recommended thus far… properly saving/force closing app/restarting ATV/verified app is up to date (minus the latest which hasn’t dropped for ATV or iOS) and there seems to be no rhyme or reason as to WHY it’s not working consistently.

Wondering if maybe it was my ATV, I even logged approximately 30 miles over the last 24 hours running Zwift on my iPad (again using all the above tricks)… 6 “test” miles over three rides yesterday evening, 1.5 - 2.5 miles each, all of which logged to the mission, then 25 miles this morning over two sessions ( 5 & 20 ), neither of which logged to the mission.

Very, VERY frustrating Zwift!!!

I won’t stop riding or subbing due to all the other benefits Zwift has provided me since signing up in January, but at this rate, I even wonder if at a 50% success rate if I can get the mission completed by the end of the month, let alone 4/16 to be eligible for the bike drawing… :frowning:


My ride from 4/4 shows up in Zwift website, the companion app, however I’m not receiving credit for it on the Parlee screen. Is there a special bike I need to be riding or perhaps wear a special kit?

I wouldn’t think so as if you read my previous reply some of my rides get counted.

I’ve not changed my kit to this point but DO swap out bikes depending on the ride. If it was as simple as that, it would have been nice to see that written up in the mission notes OR have Zwift auto equip the needed items like they do for group rides, etc.

No…just Zwift having issues

Third time now my ride hasn’t registered for the parlee mission, app up to date, annoying is a polite word I’d use

1 Like

Rode twice now since the event. Neither registered. Running of my galaxy s8 phone. Maybe wait longer after I end the ride?

Hi All,

I signed up for for this Parlee Speed Mission 3 days ago and since I have cycled a total of 37.4km Pre-Training Programme and REVO SUB2 Social), yet this has not registered towards the ‘mission’ tally in the top left corner of my home screen.

Anyone know why?



2 rides today both registered but I did check for any updates and restarted the ATV box before each ride