Paired Devices not Working in Game


(Alan Stewart) #1

So I was setting Zwift tonight and got both my HR meter and speed cadence sensor paired in the startup process.  Got on the island and started to pedal, no delay or pause, just straight from pairing screen to riding.  Had HR data but no cadence or speed, no watts, no movement of my avatar.  Tried multiple times to repair or start the process over from selecting the screen icon.  No go.  I was not able to get my avatar to pick his foot off the ground.  Opened up TrainerRoad on the same PC with the same Ant+ USB receiver and same sensors on the bike.  Worked for a 90 min workout with no issues whatsoever.

Got any ideas on why Zwift would not receive the sensor data despite being paired?


(Jon Mayfield) #2

We’re about to patch that bug, but to work around it just un-pair and re-pair your speed sensor. It’ll have you reconfirm which trainer you’re on and it should work fine then.


(Yiannis Zampelis) #3

Have the same problem for some days (lost the Jens ride for that, sadly).

Also did all the unpair re-pair stuff with no result.


(Alan Stewart) #4

I tried repairing several times but I was not asked to reconfirm the trainer.  It bounced between paired and unpaired on the devices screen with no input from me and then finally settled on listing the three devices as paired.  As I said before, then I could not use them to ride on Watopia.  Should I have forced an unpairing and then re-paired the devices?  When is the patch going to be out?


(Jason K) #5

This update went out last Friday, so it should be fixed. If you’re still having problems, try deleting your prefs.xml file from your Documents\Zwift folder, and then relaunching Zwift. You’ll have to reselect your sensors and any custom settings, but it’ll help us determine if there’s still an issue here.