Odd resistance changes in ERG mode [September 2021] [1.17.x]

Seriously this is crazy. What is the point of these forums if there is no fix. If I run my ATV and use companion app there is no change in resistance. Works fine when I use my Swift ap on phone and screen mirror. This problem came up about a week ago. Could somebody translate these forums into simple Q&A, wading through all this crap is a nightmare.

1 Like

Similar experience here. Using a wahoo kickr core and a pc running windows 10. Also have a hr monitor and all connected via Bluetooth. Exact same setup that worked perfectly before the summer.

SIM mode…… seems there’s a delay between the screen and the trainer resistance. Low resistance going uphill to start with, then the hills resistance kicks in and stays high going back downhill. Annoying but not too bad when free riding but really bad with a group. I’m putting in different efforts to others so either fall behind or run ahead.

ERG mode…… same delay as above but the impact is worse. For an easy effort following a hard effort the resistance is still high. The only way to lower the power is to reduce cadence which only increases resistance further. It gets so hard I cannot physically turn the cracks when ERG is looking for 150 W.

Raised the issue with zwift and was directed here. Seems they’re working on it which is good…. But this isn’t what we’re paying for.

Hope this gets sorted quickly

Just started the 6th workout of the ZA, when hitting the first rest period of 1 minute after hitting the 30s surge the ERG resistance didn’t drop, and the KICKR V5 went into an incredible high resistance (Spiral Of Death), couldn’t turn the pedals at my recovery power. This makes doing the workout impossible.

System running on Windows 10, using ANT+ as connection to KICKR.

Thanks Zwift!

Hi @klavan

Was this the firs time this happened to you. That is not normal for that workout. Can it be that you ended just to soon in that block?

First time this happened. I didn’t stop early, did the 30s, the resistance just didn’t drop when hitting the recovery part, making it go into the spiral of death

1 Like

I’m been having the same issues off and on for a few weeks now. ERG mode resistance lags what is called for by Zwift by 20 to 30 seconds. The problem appears to get worse the longer the ride is.

I’m on windows 10, wahoo kicker snap trainer connected via Bluetooth.

Can we get an update from Zwift support? When should we expect a resolution?

Hi @RobertP

Welcome to the forum

You might be better off using ANT+.

do you use the Companion app as a bridge.

Same issue. Very frustrating, doing training. Any idea when we’ll see a fix applied?

In essence I’m on ATV 1.17.0, and ZC 3.28.1, with Kikr Snap 2. ERG is erratic, and when you lose the Bluetooth, i.e. no sensor data, re-power on, it gets worse. I’m using Power, Cadence and HM through ZC as bridge to ATV4.

I don’t use the companion app. I can try that. Right now I’m pairing direct with my laptop.

I’d like to see some evidence that ANT+ fixes this problem before I throw more money at it. Based on the threads I’ve read, it appears this issue affects both Bluetooth and ANT+.

This is my exact issue as well. I have pretty much the same setup except I’m running off Windows 10 laptop.

I was also going to try running off iPad to see if that makes any difference.

Really frustrating and making group rides impossible. That was one of the reasons I went for Zwift!

I have no issues with ERG performance on Ant+, but lots of odd erg issues with Bluetooth via Apple TV.

My system works fine using Bluetooth and other providers, so there is a specific issue to the way Zwift controls ERG specifically though Apple Tv as the Ipad I have doesnt have the issues. The BT issue with Apple TV have been around a good while now & I think I posted on here about them at least 6 months ago, maybe more - Just getting zwift to accept, investigate and fix issues is like getting blood from a stone.

The reason I dont run Ant+ all the time is the PC it runs off isnt great and has a fairly long start time. Apple TV is great for everything bar a EG workout.

If you made that investment, I would be confident it fixes your issue.

@Lee_H I’m new to this forum, and I’m glad I’m not the only one with this issue, and as you say it’s been around a long while. So a question. Are these forums being viewed by Zwift, to assist us paying customers with this issue, or is this simply a place where we moan and complain and nothing gets done? If the latter at least we know, and we can make alternate arrangements.

It probably should be monitored and be actioned, but in reality very little is done to support the end user.

Certain items seem to get some traction, others are ignored - Customer service/satisfaction certainly isnt in the list of items zwift feels is important for the end user or themselves.

This does has have a known issue & a bug associated with it (HDWINT-3770) but what that actually means nobody knows as there is very little in the way of feedback, we dont know specifically what the bug they are looking at is etc…

Similar issue here.

Kickr Core, ATV 4K. Around 50% of my rides the load seems delayed. It’s very clear in workouts as the switches in load does not match the workout. But today I had it in SIM mode too during a race. Was dying on the flats and flying on the ascends as the load did not match my actual location on the route.

It’s super frustrating and it seems that at least once a year I waste a month’s subscription with resistance control issues :frowning:

Are you using ZC App? I think that’s where the main problem lies, and not ATV. Regardless though, what concerns me is that the forums just seems to be a place to vent frustration, but nothing is done about it. So is there perhaps another place to log a ticket and get some escalation and tmelines?

I use the ZC App only as a remote. None of the connectivity runs through the app.

Hi all. 1st post here.

I’ve just brought a KickR V5 to complement winter training ready for next years 300km Dragon Ride.

I use Training Peaks which sends my sessions over via iphone 13.

Last session was a VO2 so when I’ve gone from warm up to 260W for 20 mins the resistance has increased to the extent I can’t keep it going after about 15 mins of the 20 mins.
I stopped and had a breather…started again from scratch and same thing?

Really peed off because if this is whats going to be the norm I’m going elsewhere.

Thoughts?

1 Like

Hi @Andy_Cairns_MVCC

Welcome to the forum.

check that your FTP is set correctly. If your FTP is to high then this can happen that the workout is to hard.

Also it can be that you entered the spiral of death this is common for new people using ERG on all platforms.

With respect it’s nothing to do with FTP being set too high. I’m experiencing the same thing using the Kickr 4 (2018). 200 watts is feeling like 450 watts since this latest Zwift update. I’ve supplied a FIT file to Wahoo of a test training session via Wahoo fitness app and they’ve said the trainer is okay. I also have a Tacx Neo and that seems to work okay, albeit power fluctuating more than normal while on ERG (3 sec avg). so the issue seems specific with the Kickr

Just checking in on the status of Zwift after 6 weeks of not using it due to putting up with multiple issues for weeks with ATV. Looks like I may need to wait a while longer…