Not getting 3 minute Coffee Stop [1.41] [June 2023] [SOLVED]

hello, at the coffee stop it only gives me 30 seconds of time

I have started from the beginning and up to here in 44 minutes only 30 seconds and NOT 180 seconds, why?

1 Like

It should be 30 seconds within the first 5 minutes and 3 minutes for every 30 minutes. Obviously that isn’t the case for you and I’m keen to hear if anyone else is having the same problem.

gracias james,
The same thing happened to me yesterday, time counts, it’s always 30 seconds and I can’t run with sneakers at home like this, heh

I was granted a 3min coffee stop that I used after an hour of riding today, didn’t try anything earlier.

Undocumented 1.41 change: The coffee stop icon has changed (the cup is more bougie, improved steam) and the shade lightened. I would suggest keeping the darker shade of brown from the initial release, and the initial cup shape, but keep the steam from the updated icon. Also the icon did not change in the companion app, which updated this week.

Yesterday after the update (PC) – I did an hour group ride, saved my coffee break until the last 20 minutes, when I used it all I got was the 30 second quick break, which I had not taken earlier. After the 30-second one was over the clock started for the 3-minute break but I only had 20 minutes left in the hour ride so obviously I didn’t get to use it.

Ride #2 for the day:
It just happened again. Didn’t take a Coffee Break until 35 minutes into a 60 minute group ride and all I got was the initial 30 second option.

1 Like

Thanks, I’ve alerted our team.


Thanks for bringing this up! Question @Jordi_Riu_Popito @Luv2Pedal were either of you using Zwift Companion to initiate the Coffee Stop? This will help in tracking the issue down :slightly_smiling_face:


No @xAdrianx I had the companion app running on iOS but I did not use it to initiate the Coffee Stop - I used the PC on both attempts when I got only the 30 second break.


no companion
no, i tried it with my laptop and pc


@xAdrianx On today’s ride, I quickly used the 30 second Coffee Stop which worked as expected (initiated via PC on the PC) then as you can see, the clock never “reset” to give me another Coffee Stop. See the attached screen shots here. The timer got stuck at 29:56

1 Like

Similar issue Friday evening on iPad: updated to 1.41, but noticed that a coffee break was available prior to the 30-minute mark of the group ride (as if it were still counting 30 minutes from when I entered the pen), and that it was a 30-second coffee break rather than a 3-minute one. I started the coffee break from my iPad and not from the Companion App on Android.

Others on the FriYay Herd ride reported similar issues, but unfortunately I don’t have tech info about them, just the usual “some say”

I should also add that I did not get a 3-minute coffee break during the ride - that was probably assumed given the title of the thread but spelling it out probably helps.


No interest ! You don’t know what to invent anymore. It will ruin all future record attempts, especially over long distances. There are more important things to fix on Zwift that have been going on for quite a few years than this addition that is absolutely useless.

I’d direct you to the many posts from people who find it useful, but what’s the point?

Different features for different users with different needs. Embrace the difference, friend.


No problem I accept the difference but there are some things that I had trouble tolerating. It’s funny when you have guys on robopacer for example taking coffee breaks on every major climb (nice mentality) Very practical to avoid work. Those there should play petanque or Lawn Bowls friend !

Or perhaps others back off and allow people to train in a way that works for them. When I first started with Zwift, I couldn’t manage all the way up the Epic KOM without having to take a break, so therefore never bothered with it for quite some time. This would have enabled/encouraged me to have a go, knowing that I could take an “authorised” break if I needed it.

Or … forget having to justify it … you use Zwift the way you want and don’t complain about others doing the same while also insulting them in the process. If you can’t tolerate that, I can’t help you.


A) I’m pretty sure this is a thread to speak to issues with Coffee Stop, not to complain about Coffee Stop.

B) I’m in my late 50s now and usually can’t ride longer than 60 minutes without wanting/needing to take a quick bathroom break. The new Coffee Stop feature is VERY useful to me, I am very pleased with it!


Coffee break is really useful for sweeping if you can get your passengers to activate it all at the same time. Then the sweeper can smash it and tow a few people back to the group who would otherwise never make it and would end up doing a social ride alone. Also good for folks who are still in the pack but at risk of falling off the pace. Zwift has a lot of features I don’t care about (eg, I don’t do structured workouts and have lost interest in pace partners) but I respect that people get value from them. I’m not going to argue that Zwift should stop investing in structured workouts.


I had the 30 sec coffee stop this morning after 45 mins. Nearly had a heart attack trying to get back to the group after I returned from the loo! :sob:


I have the same problem. The 30 second coffee stop is always active. It doesn’t go away after 5 minutes as it did previously. After more than 30 minutes it is still only 30 seconds.

1 Like