Not able to connect Runpod or HR monitor

While running on a treadmill, 9 out of 10 times Zwift is unable to pick up the signal from either my HR monitor or my Runpod (using an iPhone). It’s not unusual when it isn’t able to pickup any signal at all. Other apps, like Wahoo, have no trouble finding and connecting to the devices. Am I doing something wrong?

At least I needed to Do a Runpod firmware update (pair and press wrench - it Will tell you if needed)

Hi @JuanGuillermoNL Welcome to the Zwift forums.
Bluetooth creates a 1:1 connection. If the runpod is actively connected to another app, it can not connect to the Zwift app simultaneously. Have any other apps that have connected to the runpod been manually force-closed?

Likewise, the Runpod should not be connected to the iPhone directly in the way you’d connect your earbuds. If the Runpod is connected in that way, you should go to the iPhone’s settings > Bluetooth devices, and manually remove it from the list of stored devices.

Thank you for replying, @shooj. I already made sure the runpod isn’t connected to any other app nor is it connected to the iPhone directly. Yesterday in the gym I could not establish a connection between the Zwift app and my runpod and heart rate monitor. When I closed the app (and even restarted my phone) it still didn’t work. When I tried connecting the Wahoo app, there was no trouble whatsoever.

What HRM are you using?

Try putting a new battery in the ZwiftPod to see if that resolves the issue.

Thanks for your reply, @Paul_Allen. I already tried putting a new battery in the runpod and it did not resolve the issue.

@JuanGuillermoNL
So far, so good. When you attempted to connect to the Zwift app, were you prompted to update the runpod’s firmware? That is a step you should have seen.

@shooj, no I was not prompted to update the firmware

At least I had to push on the wrench before I was prompted to update firmware

@Carl-Magnus_Cedercre @shooj after clicking on the wrench I wasn’t prompted to update the firmware either

Sorry; I don’t even know if I can check the current release… and I’ve had my own share of issues in getting it connected. Lets see if I have lick today or not…

Hi Jan, thanks for posting! I’ve been having the exact same issue with my Zwift Run iPhone (build 1.044368 and iOS 13.3). I had given up after a couple fails at the gym and been riding, but now am ready to give it another try. I even tested the batteries (tried two) with a meter and they show good. I put a battery back in and launched Z-Run and it saw the footpod immediately! I clicked the wrench but it wouldn’t let me do anything other than calibrate. Since I’m not at the gym this moment I closed the app, removed the battery and will try this again when I’m at a treadmill (will be tomorrow = Tues, Jan 7) and I’ll report back then. If the failure continues I’ll open a support ticket, too. Good luck! --Beth