Milestone runpod and AppleTV connection problems

I run over my lunch hour and am doing the half marathon training program so this is driving me crazy. I can’t afford to spend 30-45 minutes trying to connect to zwift every run.

I’m running zwift on the apple tv and use either a milestone runpod or an apple watch to connect. I had this problem for a couple months over the winter but then all of a sudden it went away and the runpod would connect as sooon as I entered the game. Then a couple weeks ago I moved the pod to a new pair of shoes and it started happening again.

When I enter zwift I can pair either the run pod or the apple watch for speed. I prefer the run pod because it also shows steps and seems to work more consistently and is easier to calibrate, when it works. Both the watch and runpod come up when I start to connect and show that they are connected when I choose one. The runpod shows all signal bars full and the bluetooth logo and everything indicates that its connected but it won’t show any speed or steps. 0mph and 0steps will show briefly but it doesn’t increase above 0 and then it goes away. The avatar stands there and stretches. I can go back in and try to connect again and the same thing happens regardless of whether I choose the pod or the watch. This goes on for 30-45 minutes and eventually the watch will link up and start to send data to the app. I’m on a treadmill within 10’ of the appletv. Apple watch as a heartrate monitor connects and works fine. The runpod will sync with the milestone app.

I’ve tried:

  1. With and without the iphone companion app.
  2. New battery in the run pod.
  3. Turning off the fan and bluetooth speakers.
  4. Making sure the milestone app is closed on my iphone.
  5. rebooting everything.

I’d blame the runpod itself but the applewatch is only marginally better.

Any help or ideas appreciated.