Run Pod Connectivity

Zwift. Help me like you because I am beyond frustrated.

I have the Zwift Run Pod.
I can connect to the pod and walk/jog with no issues.
I have tried calibrating my pod numerous times only to fail at high speeds.
I’m using an iPhone X, updated to software 12.1.2
I’ve tried WiFi on and off during runs thinking this was a network error, to no avail.
I’ve disconnected any other Bluetooth device so that my pod is the only thing connected to my phone.
I’ve replaced the battery in my run pod thinking that may have been the issue- but that yielded the same results.

As mentioned above: I’ve been able to walk and jog with the run pod with okay results. However, I’ve spent more time on the treadmill just trying to get this to work that I’m at the point where I’m over it. I’ve logged 2 miles in the app, when in reality I’ve run 4 miles on the treadmill.

Zwift, please help me out here, what I’m I doing wrong?

Hey Benny,
Thanks for the heads up! We’ve been aware of these issues and they should be addressed in a coming update.
We’ll check in on everyone once that update is released.
Thank you for writing in!

cannot pair my run pod with my iPad despite every possible known method of troubleshooting. i’ve only been able to run 3 miles successfully using zwift run pod. i’ve spent more time troubleshooting instead of actually exercising!!! any help??