Milestone Pod Connected but no data


(Brian O'Connor) #1

Hello,

I bought a milestone pod several months ago, and initially had tested it to work with my iPad on a quick test run - it worked fine. Now that the weather is getting colder, I went to the gym this morning to do a run on Zwift at the treadmill there.

At first, the iPad initially saw the Milestone Pod - great. I went to start running … and no data from the pod to the iPad. No matter if I walked or ran, even for several minutes, no data would show up on Zwift - an idle avatar.

I tried on my Android phone and my Macbook Pro, and same issues. The whole time the Milestone pod shows as connected, but just no pace data or cadence. For posterity as well, my HR band does show data on Zwift, so the Bluetooth receiver is working.

I’m trying to narrow down as to whether or not this is a Milestone issue or a Zwift issue. Any advice would be great.

Thanks.


(Vincent W.) #2

Hey Brian, sorry Zwift isn’t working as intended for you. :frowning:
Did you get a chance to test if the Milestone Pod works separate from Zwift and registers your steps?
You can also sync your pod to your Milestone app, select the milestone pod icon and check your battery life in case the battery is low or dead. You can do this without the app by tapping on your Pod and if a colored light appears your battery is ok.
Another step is to refresh the pod by taking out the battery, waiting for 2 minutes, then putting the battery back in.

Make sure your Pod is not connected via native Bluetooth on your iPad, but rather straight to the App. If it’s linked via Bluetooth on your iPad, disconnect it then open the app and sync it there.

Let me know if any of these steps help!


(Brian O'Connor) #3

Pretty sure the pod was connected directly to the app, and not the iPad itself because Zwift was showing it as Connected on the pairing screen.

Milestone support had me take the battery out as well, so I’ll report back during my next indoor run to see if that fixes the problem. The pod reported that the bettery was “Ok” before the reset, and then “Full” after, so maybe there was a problem with the battery connection.

Will report back
Thanks.


(Brian O'Connor) #4

To follow up on this - Milestone support had me reinsert the battery on the pod, and after doing that I was able to see both pace and cadence in the app and it worked great from there.


(R Fish) #5

Thank you very much for this thread (to the person who sent in the problem, Brian, and the response from Zwift).
Last week I reported the problem that my avatar wasn’t working on Swift run with my MilestonePod. I have been using it at the gym on the treadmill for a couple of months and everything was fine. Took a couple weeks off from the gym (the weather was nice enough to run outside) but went back to the gym last week And my avatar just stood there and warmed up even though Zwift (run) said that my foot pod was connected (and subsequently node running that was being recorded). My heart rate was recording but no movement. I contacted Zwift support for a chat but after waiting a while I took the email option. A lot of suggestions were made (Almost all of which I already had finished doing) but nothing seemed to work. I even took out my battery (that was not suggested in the email from Zwift) and put it back in but that didn’t help (but I only took it out for a couple seconds and put it back in right away). I was going back to email support today and I searched on Google for no data from MilestonePod on Zwift run and I saw this entry. I took my battery out for a couple minutes put it back in and everything is fine. I still think this is kind of strange because I have two different milestonePods in two different pairs of running shoes and the same problem on both of them. Any clue as to why this is happening?
Bottom line is I really appreciate this century in the form it’s fix my problem. Thank you both


(R Fish) #6

Noticed a couple of autocorrect mistakes when I read my post.
Bottom line is that I really appreciate this entry on the forum - fixed my problem.
Thank you to both Brian and Zwift support.