Zwift RunPod and Milestone App


(Charles) #1

I just got a Zwift RunPod and I noticed the Milestone logo on the back of the unit. I downloaded the Milestone Pod IOS app but I was not able to pair my pod with the app. I had no trouble connecting it to Zwift. Is the Zwift Pod compatible with the Milestone App for my outdoor runs?


(Vincent) #2

Hey @Charles_Dauphinais were you able to follow the steps from https://www.milestonepod.com/get-help/faqs/:

Step 1: Download the free MilestonePod App.

Step 2: Turn on Bluetooth. Do not pair the Pod with the native Bluetooth setting of your phone or tablet. The Pod pairs within the App only.

Step 3: Register using email (or Facebook). Enter your profile information.

Step 4: From the Menu, choose ADD/RESET A POD. Choose your Pod on the list by matching the last two characters of your Pod serial # found on the bottom of your box and inside your battery cap. (i.e. If your code was D0:11:11:A0:11:A1, look for “A1.” Character range is 0-9 and A-F.)

Step 5: Enter the last two characters of your Pod serial #. Hit SAVE.

Step 6: Enter your shoe information. Enter the starting distance already on your shoes, if any.

Step 7: Accept any firmware or App updates, if any.

Step 7: Head out the door! Keep in mind: although no lights will appear on your Pod, it is on and tracking your workout.


(Charles) #3

I did follow these instructions. My problem is at Step 4. The pod does not show up in the list. I tried turning bluetooth on/off and removing the pod battery. I also tried on multiple devices (Iphone XS and Ipad Mini 4).


(J Bee) #4

Another datapoint - same problem here but with Android - no problem connecting to the Zwift android beta, but the MilestonePod app is stuck on scanning in step 4 above. I’ve tried all the approaches that I could find web searching - tried the vanilla approach above, restarting phone, removing pod battery for 30s-1m and trying, bluetooth on/off, reinstalling app etc. to no avail. The app just doesn’t seem to see the pod.


(Vincent) #5

Hey @Charles_Dauphinais @jbee so we’ve got an answer for this: The MilestonePod app currently filters out anything that is not broadcasting MilestonePod as the device name. An update to the MilestonePod app should be released in the next few weeks to allow the RunPod to sync with the app.


(Charles) #6

Thanks @Vincent Great news! :grinning:


(J Bee) #7

This is awesome! thanks @Vincent !


(Kevin Smith - Big Sexy Racing) #8

Will the runpod pair with a Garmin fenix3 like a normal footppd? My watch can’t seem to find it.


(G uy ZHCC Capo Bastone) #9

Do you have any timing update? I got it for my son in law but if he cant use it outside as well, it will be replaced. Many thanks


(Charles) #10

The update came out yesterday on IOS. Update the app and the Zwift Pod should be supported.


(G uy ZHCC Capo Bastone) #11

Many thanks. I was watching the andriod one but he uses ios so perfect.


(Charles) #12

@Vincent I updated the Milestone app, but I am still running into problems connecting my pod. The Pod is now detected, but every time I try to connect it, I get an Error message ‘‘Error as occurred’’. This problem is present on both my Iphone and Ipad. I tried turning bluetooth on/off, phone on/off, closing the app, removing pod batteries, etc.

EDIT: I contacted Milestone support and they answered my email in less than 5 minutes :smile: It is a know bug and it will be fixed next week. They have a workaround, but you need to email them after creating an account inside the app for them to manually fix it. Here is their answer:

''Thanks for contacting.

We have found the bug, it will be fixed mid next week.

In the meanwhile I changed some settings on your account so that you will be able to work it out.
Please kill the MilestonePod App (not even running in the background) and reopen it.

It should work for you now.

Let me know.

Sorry for the trouble.

Best,
Meir | Milestone Sports’’


(Vincent) #13

Glad you got your answer Charles! Hope you’re able to have fun with the pods. :ride_on: