No XP showing at all Tour of Watopia Stage 1 [March 9 2022] [SOLVED]

I finished 1 tour of watopia event (which I earned xp points in) , then when finished joined another TOW event. I did not earn any xp points in the 2nd event. I use apple tv and i did not force close app between event.

Well, this has already been discussed here. You have to save and exit your ride to the main screen after the first event, then join again for the next event. Otherwise, you wont receive XP for the second event.

I rode three ToW (B)rides in a row today. The first one was with no issues but I didn’t get any base or double xp’s from the second or the third ride.

@Niko_Koivisto1738 :wink:

What’s the status on the fix for this?
The ”workaround” doesn’t always work.

No XP points on first lap of C stage 1, but ok on 2nd lap. Max points on B stage 1 next day.
No XP again on C stage 2 this morning 8 CET, so gave up after 9km.
Using Windows 11.

Both the times it didnt work, i joined from another ride - will know better next time. Pity Zwift couldnt have let us know of fault by email.

Still not solved. How hard is it to count km, and give 20XP or 40XP?

Started freeriding in Watopia, 1km, then joined with join button in lower left corner.
First KM, no XP, then 40XP from 2nd km.
Not that I need those XP’s anyway, been stuck at L50 for 15+ months…
Only a few more badges to get before exploring other platforms. Just saying.

Looks to be fixed with today’s update…

1 Like

Thanks Dean. You beat me to it.

Everyone: please update to game version 1.23.1 before your next Tour of Watopia event, and allow a few minutes for the download & install.

3 Likes

“We are unable to credit accounts with additional XP” is an unacceptable response (imho). Why not?

7 Likes

Worked perfectly today. Thx for fixing!

I’m not needing XP but as an FYI @shooj, I think the bug is still there.

I did a ToW last night and didnt get XP till 14km mark(ish).

  • Win10, Zwift ver 1.23.1 (new Home Screen)
  • Went to Join event from Home Screen Event Card
  • Dumped into free ride on Watopia
  • Immediately "join"ed event (2-3mins to go) - slowed peddled while I fluffed around

Group I was in also had one person mention they werent getting XP

Snips from my log file from his comments:
[17:12:32] Chat: 2147328 (GroupEvent): Anyone else not getting XP?
[17:13:18] Chat: 2147328 (GroupEvent): Getting nothing
[17:13:35] Chat: 2147328 (GroupEvent): Did a short warmup prior, might be a bug
[17:19:34] Chat: 2147328 (GroupEvent): Mine started after 10km now

Thx for that as well. I will keep an eye on this tomorrow.

@Dean
Yeah - i’m seeing that you had already updated to 1.23.1 when you did yesterday’s ride. If anyone else was still on 1.23.0, they’d still see this bug, but that doesn’t explain your case.

By any chance - is your prefs.xml file using the world hack?

I didn’t think to ask him … doh

No but I’ll do clean reinstall when I next hit ToW and report back.

Thanks Dean.

If anyone else is still seeing zero XP during a Tour of Watopia event AFTER you’ve updated to game version 1.23.1 - please flag it up here. Thank you.

@shooj Reinstalled (including wiping /program files (x86)/zwift folder), didnt mod any files (I normally only remove RideOn image and mod for FPS), followed same process as noted in my above post, and starting getting double XP from the 1st 1km.

So I’ll pop my FPS xml setting back in and carry on … will post up if it occurs again.

1 Like

@Dean
Thanks for following up. Glad that got figured out quickly.