No way to restore purchase on Apple Tv with the new UI

The button to restore purchase is impossible to click with an apple tv remote. I restarted my zwift membership using my phone and now when logged onto apple tv it says trial expired. a pop up appears saying buy membership or restore purchase by there is no way to click restore purchase button on an apple tv. I downloaded the app on my phone and the restore purchase button works as you can touch screen but I get a network error when pressing it. Bit of a joke guys.

Did you try exiting Zwift, logging back in and then trying the “Restore purchase“ button? Before the new home screen update this worked, it didn’t work without exiting Zwift first. The button could not be clicked, just as you described. Pretty annoying when you’re in the middle of an event. I mailed Zwift about this several times, never got an answer that acknowledged the problem.

Uninstalled zwift and tried again but I don’t think the restore purchase button is even assessable with the apple tv remote, on the old UI it worked fine. I logged onto zwift .com and tried to join again and it has seemed to have sorted it but im not sure if it charged me twice yet.

Are you paying via iTunes? From what I understand this was always a specific iTunes problem. The only help I ever got from Zwift was the suggestion to use a different payment method.

Yea paid through itunes. Previously on the old UI down the bottom left of the screen it would say join now or restore purchase and would work for me. The same option comes up on the new UI as a pop up but there is no way to press the restore purchase button on apple tv as it seems to have been designed for a touch screen.

For some reason Zwift seems to be keen to get rid of customers who pay via iTunes. I can’t think of another reason why they don’t fix this problem that pops up regularly.