No watts, cannot ride

i am experiencing a issue with no wattage. everything is connected like i have done a 100 times before but now no watts registered by zwift. I use a kicker snap

No cadence showing either… is there a verification check that Zwift does that if you have no cadence you can’t have any power?

NO. Not true.

1 Like

Try connecting with ANT+, looks like you have that as an option. Make sure it is the FEC option.

1 Like

Can you connect the trainer to the Wahoo App and see there is watts displayed.

1 Like

thanks for the suggestions. i will try the wahoo app and the ANT+ vs Bluetooth. note there is not cadence as i was not pedaling at the time of the screen shot. cadence is working.

downloaded the wahoo app and i showed watts, it also updated the wahoo firmware and maybe that fixed it. zwift shows watts so it looks to be working now. thanks all…

1 Like

spoke to soon. everything connected but no watts again. it worked two days ago now once again no watts. wahoo app also shows no watts.


With the Wahoo app showing no watts, it looks like it’s time to contact Wahoo support. Probably the trainer itself is faulty.

maybe. i did get it working with the Zwift phone app. why i am not sure. i little flaky (dropped from time to time) but it did work.

Sure. But it could be the trainer is failing and only working intermittently. The fact that you saw it not producing watts on the Wahoo app as well as on Zwift is a big red flag.

ok thanks, i will contact Wahoo support if in continues.