No uploading strava and garmin cannot even get acces to my workout on zwift an companion

so i completed this workout yesterday and it didn’t upload on third-party platforms, looks like it’s visible on my zwift feed but when I try to consult it to have acces to the .fit file or take a look at the activity it’s stucked loading so I cannot even consult it on zwift and zwift companion

Any idea where it comes from?


Activity upload resulted in corrupt file.

Zwift does know of the activity - but accessing it’s details is prevented (either intentionally or unintentionally, i.e., a bug).

This activity corruption is also the cause for the activity not being uploaded to third parties.

You can, however, manually upload the activity to Strava (no can do for Zwift…)

(reporting from experience, lots of it; often blamed for poor internet connection)

1 Like

im having same problem two days in a row , did you solved it ?

My rides upload to zwift and Today’s Plan but Strava stopped working.
I have to upload manually (after downloading it as a file)
I’ve disconnected and reconnected and it still doesn’t work.
Any other things to try?

So the problem was that my internet connection crashed so many times that zwift couldn’t save the activity. I’m using zwift on my computer, I could find the fit file wich is automaticaly saved every 10 min in my zwift local folder and manualy uploaded it in both strava and garmin.