No Steering for Apple TV

Wahoo Kickr Bike, Apple TV, Companion are my set up. Both Wahoo bike and Zwift on Apple TV are updated to latest version.

In spite of that I don’t see the steering option.

Can you help?


Same problem for me. Steering icon shows as connected on startup screen.
When using Zwift on laptop it works fine but not with Apple TV. Very frustrating.

My Apple TV won’t even show the “Steering” icon at Pairing screen.


And now it works again…weird.
I did the following:
Rebooted Apple TV and checked for any updates - none found.
Connected Wahoo Kickr to wahoo app on tablet and changed gear selection in config to the eShimano (this changes the button assignments)
Loaded zwift app on tablet.
Loaded Zwift on Apple TV
Tested in free ride mode - steering icon shows, steering warning dialog shows and steering now works.
Ended ride.
Did a workout ride - steering dialog not shown but steering works fine.

oh… I thought of that idea… and forgot to try out.

Thanks for that. “eShimano”….



What’s the firmware on your Kickr Bike? I don’t see eShimano on mine.

I have the following
Shimano Synchro
SRAM mechanical

Firmware 1.16.0
Hardware 4


SRAM eTap is what I selected.


Is steering only for MTB on steering specific route such as the one in Titans Grove?

Or steering work on all bikes on all routes??


All routes except for the trial MTB steering route as it will only work with the app and a mounted phone on handlebars as was and still is a beta feature.

it’s weird that I can’t get the steering to work.

I chose the bike type you mentioned(the name slips my mind now… something like e-Something.)

In the pairing window, release note said I should see additional connection window for steering to the left of “heart rate”. I don’t see that. All I see is “heart rate”, “power” “cadence” and “controllable”.

Within a route, the small inside button on both handle are supposed to activate left & right, but nothing happens.


You need to see that steering icon for it to work…

Have u tried updating the wahoo kickr bike firmware?
Also make sure that everything is bluetooth paired with Apple TV.
Power cycle Apple TV and Kickr, make sure that Apple TV, Zwift app and companion apps are fully updated. Also check that kickr cable plugs are seated correctly in the sockets.
If still not working try loading Zwift on a laptop instead of Apple TV to help track down which device or app is misbehaving.
As a side note I am using latest Apple TV 4k.