“No Signal” in the pairing screen

Hi @Martin_Harris2

How do you connect to your watt bike, BLE or ANT+

What options do you see on the paring screen.

Same issue here. Two issues actually.

  1. When I want to login the system finds something wrong with my password. I can use the same password to login to zwift via the web etc. This is a problem that I see has occurred before for others. When I use the workaround others have found (pretend to create new user but entering my same user details, tells me I already exist, go back to login screen and I am able to get in.
  2. Once I do manage to login, my Windows 10 laptop connects and pairs to my sensors (inride, tickr, wahoo speed/cadence) but then shows No Signal for all 3 the same as shown above by others.

This was all working fine until the recent update.

Is there any news about this topic, because I have the same problem with my Wahoo KickrCore since a few days. Very frustrating

Unpair everything then start pedaling to wake up your trainer, then start the pairing session.

I have already tried everything without success. The error occurs on both iPhone, iPad and Macbook. I will test Windows PC tonight.

Sound like it is your trainer, did you try it with another app?

Wahoo Fitness App via iphone and Bluetooth works fine. I also tested the connection via Bluetooth the Wahoo Element Roam and this works too.
I just borrowed an ANT+ adapter from a friend and will test it with Zwift right away.
At the same time i opened a Suportcase at Wahoo and wait for answer

Still the same here… Anyone knows how to fix this? I hate zwift already…

1 Like

I started getting the ‘No Signal’ from the connected Computrainer after having tried Running where I connected a Sole F85 Treadmill as arunning speed source. When trying to do some bicycling the next day, I was not able to get any signals frrom my Computrainer using Zwift, but it worked perfectly well using other SW.
After some investigation, I found that after connecting the Treadmill for running it was listed under both : and tags in the prefs.xml configuration file. will normally list my Computrainer ID (as defined in the knowndevices.xml file.
In order to get my Computrainer to work again when switching to Cycling, I have to first edit the prefs.xml file and replace the ID listed under to list the ID og the Computrainer instead.
This has been reported to Zwift support, hopefully they are able to fix this in a further release. I would really like to see seamless support for both my Sole F85 Treadmill as well as my Computrainer without the need to manyelly edit config files…

Here is the same problem, No signal, connected. I try everything but it doesn’t work. This is something new, I am Zwifting for 4-5 years and this is the first time to be frustrated and dissapeared.
20200111_161551|690x432
Any update about this problem? Thanks

Grrrr - I’m having the same problem as of tonight and missed my TdZ start after wasting warmup trying to debug - and a bunch more after…:rage:

Tried the above “fix” sequence (multiple times…) and no go. Rebooted AppleTV, iPhone and trainer (STACZero Power) and Zwift still won’t get signal (pairs / connects but no power or cadence).

Bluetooth BLE connections all around. HRM connects and provides signal but trainer gets “No Signal” (same deal after multiple re-pair cycles).

I can connect and get signal / data no problem in other apps… just not in Zwift.

Device details below:

Zwift 1.0.44368 on tvOS 13.3 on aTV 4K
Companion 3.10.0 (657) on iOS 13.3 (iPhone 8)
STACZero Powermeter v129

1 Like

Just had the same issue.

PC + Samsung Bluetooth dongle worked fine for a week.

Today, lost connection during my ride.

Had my iPad (companion App) + iPhone (Wahoo Kickr App) + PC (Zwift App) and TV connected (TV with HDMI from PC) + Wahoo Cadence sensor.

After rebooting and unplugging everything, it worked again. Leave everything unplugged for a few minutes. Also disconnect Bluetooth on iPhone and iPad.

My startup order:

  1. PC + Bluetooth (let it search for a minute before powering the smart trainer)
  2. Wahoo Kickr
  3. Wahoo Cadence sensor
  4. iPhone
  5. iPad

Hope this helps.

rgds,
Jeroen

First recommendation, disconnect Wahoo Kickr app from Bluetooth and maybe do not use at the same time as Zwift! Even though it worked fine for me for a while.

First I disconnecthed

I’m having the same problems. MacBook pro and Wahoo Core, and keep getting “no signal”.
I’m also not able to do a spin down.
Note that this is inconsistent. Some days it works great with no problem, other days, it’s an hour of fiddling and rebooting.

Same problem. I’ve tried the work around with opening/closing/reopening the companion app and the bike connects for maybe 10 seconds and then goes back to no signal. I had used this for about 2 months with no issues, and now I’ve been unable to ride with Zwift for about 2 weeks.

Frustrating… especially with isolation. My trainer is connecting to other apps fine, it’s just Zwift that is having the issue. Please let me know if anyone finds something that works!

have you updatede your tacx? I had the same problem today, but updating fixed the problem!

Hi, did this get fixed? Been using Zwift | Wahoo Kickr | Mac mini for over a year with no issues. After the latest Zwift update the Kickr displays that its ‘Connected’ but with ‘No Signal’

I’ve tried updating Mac OS, reset all connections, the Kickr isn’t connected to any other apps (inc. iPhone 11) Man, I’ve turned it on and off so many times and still no joy!

I’m self isolating at the moment and this is the only thing that will keep me sane! Massively frustrating… can anyone help?

Still no luck with me. Everything is updated.

I’m going to be super bummed to switch programs, but I dk if I’ll have a choice pretty soon.

Wahoo organised mine to be collected and swapped out for a brand new unit.

Finally am up and running! I have no idea what changed.

Just bought a Kickr, it’s connecting fine, but my Garmin HRM isn’t - getting this ‘no signal’ carry on … WTF?

Self-isolating also…