No Ride On during rides


(Thorsten Zwieback TFC Racing) #1

In the last week or so I have noted that I do not receive any Ride On while in a group ride or race. Neither does the thumb appear on my screen, nor do I collect any in my back pockets. Everyone around me is getting plenty of Ride On, so I thought I was just that everybody hates me, but I get the notification in the companion app after my ride finishes.

Apple TV 4K
Latest Zwift version
Elite Direto (Bluetooth or ANT+ issue arises in both)
Companion app on iPhone X


(Aaron Zwanzig) #2

I had the same experience just this morning in a group ride. “High fives” (for Qhubeka) were raining down around me, but I got none. Looking around it seemed most everyone else had them spilling out the top of their pocket, but mine was empty. Looking at the activity stats on the Zwift website shows that I actually received 16! I also noted that the message board was empty. It’s possible that I was the only one to say anything, but it seems unlikely.

Apple TV 4k
Latest (yesterday’s) Zwift update
Android Companion app


(Vincent W.) #3

Investigating! @Zwieback @Aaron_Zwanzig were the Ride Ons you saw in Zwift Companion applied to the current ride you were on, or a ride prior?


(Aaron Zwanzig) #4

@Vincent: I don’t understand the question. What do you mean by ride-ons that I saw in Zwift Companion?


(Thorsten Zwieback TFC Racing) #5

Group ride TFC, Sunday 20:15 UTC

Ride On received according to Companion app: 8
Ride On received in ATV4k during ride: 0

Oh, and messages seen during ride: 0

Frankly, this is not worth the price rise to £12.


(Thorsten Zwieback TFC Racing) #6

@Vincent - any updates, please?


(eric bednarz.bike) #7

Same thing here, Apple TV 4K. Every other group ride or so I don’t get rideons during the activity. Yesterday I saw 25 afterwards. The bigger problem for me is that I don’t get and can’t send group messages either when that happens.


(Tomas Andersson Szr (B)) #8

Same fore me today. No ride ons and no messages.

Apple Tv 4k
Android companion

Tomas


(Guy Badman) #9

Same for me on the last couple of rides. Using Apple TV4K and iOS companion app. All apps up to date.


(Thorsten Zwieback TFC Racing) #10

I have opened a support ticket for this, and for the lack of group chat, since this topic appears to be somewhat neglected or ignored by Zwift.


(Lin Alan) #11

You may not see Ride Ons during a ride if the person giving them isn’t giving it to you during the ride. A couple of examples:

  1. You spam/give out a Ride On to those in your near vicinity by pressing the little circle around your location on the companion app. You finish your ride. The other person(s) finish after you. They see you gave them a Ride On and to be courteous, they look you up and give your activity a Ride On as well.

  2. Your Zwift buddies/friends log in after you have finished your ride. Look you and your activities up and give you a Ride On.

In both of the above cases, you’d never see the Ride On while you were riding. The Ride Ons would appear after the fact. This is normal and to be expected. Give it a try, look up a buddy. Check out his activity list. You can give Ride Ons for any ride going back weeks as long as you didn’t already give him one.

As for Ride Ons in a group ride where those around you seem to be getting them. This also does not necessarily signify a problem. When in a group ride, to give Ride Ons to someone else in the group, it has to be one at a time. If you suddenly see 5 Ride Ons rain down, then someone from outside of the group sent them. Perhaps you weren’t the one of the closest five or whatever criteria Zwift uses to give out the Ride On.

If you’re not seeing any chat/messages, that would be a problem. Try sending a message yourself and seeing it appears on screen. If not, you definitely have a problem. I have only had this happen once.

Lastly, I too am using an Apple TV 4K and an iPhone.


(Thorsten Zwieback TFC Racing) #12

The Ride Ons were given while I was riding. As soon as I finish the group ride, they are there to see in the Companion App. I can see everyone else’s RO appearing over their heads and in their pockets, but not the ones I receive during the ride.

I would be interested to know if others can see them arriving for me, I will have to try doing a group ride with a friend and get them to see what happens when they give me a RO.

The chat is of course the bigger problem, the RO are just a bit of fun.

I can see my own messages appearing, but not anyone else’s. This is a real problem during group rides, as you can imagine.

During a free ride, all of this works, by the way.


(Gleb Chugin @ietottoje) #13

same here ATV4K, seen zero Ride On’s on yesterday’s hour long “free ride”, my attention was grabbed because of empty jersey pockets, which always have some stuff in it by the end of a long ride. I can’t remember about the chat tho because it was VO2max intervals day :slight_smile:

And today at the hour long group ride there was not a single message in chat except for those two I written (empty in both ATV4K and iOS Companion app) and same, no Ride Ons even tho I’ve seen how people around receive those.


(Jesper Rosenlund Nielsen [ZwiftHacks]) #14

I’m not quite sure why you see a difference between group rides and free rides but suggest that you verify that your firewall(s) allow UDP traffic on port 3022 and TCP traffic on port 3023. If TCP port 3023 is blocked it will block e.g. chat messages.


(Vincent W.) #15

No Ride On’s seen on Zwift or Zwift Companion? Still investigating


(Gleb Chugin @ietottoje) #16

yesterday it started to work again, today everything was fine as well


(Vincent W.) #17

Hmm that’s interesting, awesome! @Thorsten are you still having trouble with this via group rides?


(Thorsten Zwieback TFC Racing) #18

I did a race (Innsbruck Team Challenge) yesterday, and everything worked as expected. I’ll try a group ride in the next couple of days, fingers crossed!


(Karen McCarthy) #19

I am having the exact same problem. No ride ons during ride but they show up in Companion afterwards. Also no messages on screen. I am on discord and asked others to give me a ride on and they did not show up. Empty pockets for me. I verified that there were plenty of messages going on too. I could see messages during my free ride but not any group rides. This has been going on for about 3 weeks. All worked well before. Apps are updated. Using Apple TV 4K too.


(Vincent W.) #20

Thanks for the heads up Karen! Investigating. Has this happened constantly or just a one time thing?