No resistance felt on inclines but speed reduces


I have a Tacx Neo 2 running on Apple TV 4k, all updates are loaded to Apple TV and Tacx Neo.

When riding and hitting an incline no increase resistance is felt on the trainer however the virtual speed reduces comparative to effort so clearly the incline is being taken into account.

This is not the experience I want, I wish to be able to use my gears relative the climb.

To check that my Tacx was OK I ran the RGT app and the Tacx getts resistance on the RGT climbs maybe a little to much.

How do I fix my Tacx Zwift interface to work properly?

Thank you for any help or ideas.

It sounds like you might have ERG mode turned on, which is keeping your wattage output static. Not sure if that’s the case, but you might want to check it.

1 Like

Fairly sure you have set trainer difficulty to zero.

Go to menu and move the trainer difficulty to full


You’ve probably got this covered, but on the Paired Devices screen is your Controllable device (lower right icon) showing as connected?

1 Like

Hi on Apple TV, no option to switch ERG, in fact no ERG visibal as an option. I’ll delete the app and reload. The only option regarding difficulty in relation to inclines is set t max. Also not vibrating over rough ground. Subscription cancelled from mid feb as no longer see Zwift as value, shame really.

Some part of your trainer is probably still paired to another app

You cancelled because you’ve got an issue? Hard to see how this can be a direct fault of zwift when there is hundreds of thousands of people that have it working just fine.

Maybe continue fault finding…

1 Like

Hi thanks for the reply, I went for the delete everything option and start again, it would appear to have worked. Thank you for your help, much appreciated.