Newby - can't get started

Hi all,

Just got my Wahoo Kickr and heart band. Installed everything, updated everything. Attached my bike. Got a subscription on Zwift. So far so good.

When I start swift, it sees the bike and the heart band as connected. Then when I just start to cycle, the display shows no information. When I try a training, I do see a lot of information on the screen but they stay 0, and when I cycle, my rider is not moving.

When I open the Wahoo app, cadence, heart, speed etc is registered.

Help!

Everything is connected and I have paid… why doesn’t my cyclist move in Zwift.

I think I know what it is, my subscription is still pending :frowning:

No subscription, the trial doesn’t even start

1 Like

Can you please provide the complete information on your setup (trainer, HRM, computer/tablet/phone/Apple TV), etc. This might help users to diagnose your issue/s. Also, if you’re connecting via Bluetooth, be sure you have disconnected from the Wahoo app before trying to connect to Zwift.

3 Likes

hi Nigel,
Thank you for responding, but after getting a Zwift membership using PayPal last night I found that my membership is still pending. That means the 7 days free/trial period is also not activated and I assume that is why my Avatar refuses to cycle…

I don’t think there is a helpdesk available to call (sitting here in my cycle clothes mega disappointed).

I don’t know, I think if you were able to log in, pair your kickr, and see your avatar on the side of the road then is should be active. I am leaning towards an issue with the signal from the trainer.

1 Like

I don’t think that this would be the issue - you get 25km free, so it would still move!

I’m not an expert (so will defer to others who are) but have you checked to see what devices are connected to what components?

What I found was that if I had the Wahoo app open, that would ‘hog’ the bluetooth connection between my Kickr Core and so the Zwift app wouldn’t connect or would drop-out.

The consequence is that now I turn all my bluetooth connections off on my non-Zwift phones (on which I’ve got the companion app), turn my Garmin bluetooth connection off, and all runs smoothly.

Might be worth trying that first - don’t have the Wahoo app open while you ride and see if that works?

2 Likes

Did your device say connected when you open Zwift?

As far as I know, my Wahoo app was not open. But I will turn off the bluetooth of my phone, startup the Wahoo kickr and Zwift fresh and see if it makes a difference.

Trainer, Wahoo Kickr
HRM, Wahoo
computer W10

Bluetooth OFF on my Phone and still my Avatar is stuck watching the 300m sign.

is your trainer connected to windows bluetooth prior to opening Zwift? If so, forget the device in the windows setting and start Zwift.

1 Like

Just to keep it simple to begin:

Close all the apps on your phone
Disconnect your trainer from your bluetooth (e.g. forget the trainer)
Make sure you’ve got no other devices on bluetooth nearby
Open Zwift and pair the trainer

Does that work?

2 Likes

Apps closed.
Wahoo kickr or Heart rate is not as any of the bluetooth devices. I will turn Bluetooth on and off on my PC
I have no other bluetooth connected
turned off bluetooth on my Macbook pro (which was closed).

Just noticed that both say connected but also say no signal in the begin screen

1 Like

As an alternative you can try bridging the signal with the companion app as long as they are both on the same wifi network. Also, one issue another user had recently was that the “use built in bluetooth” was not selected in the upper right hand corner of the pairing screen. I think there is a settings icon there. Double check that is enabled.

2 Likes

hi Mike,

thank you, it was not perfect but i managed to get my first 20 min in. Speed and Power were visible, cadence unfortunately not and that should be visible with a Wahoo Kickr.

Thinking of buying an ANT Dongle… then I won’t have the bluetooth hassel anymore

2 Likes

Read somewhere that turning off defender or managing fire wall rules helped.

Going to try that tomorrow.

Ant+ is your friend… When pairing your Kickr will show two Ant+ connections…be sure to connect to the Fe-C option.

3 Likes

No clue what that means but i am sure it will pop-up somewhere… :grinning_face_with_smiling_eyes:

Cadence solved… I thought when it sees my Kickr it sees the rest too… but no, for cadence I had to select the kickr too :slight_smile:

tried cycling a bit first, the logging in (found that in a forum somewhere) but no, still had to connect via my companion.

Lets hope the Ant comes soon :slight_smile: