New to Zwift and LOST!

Hi,

Apologies if this isn’t in the right place but I need a bit of help!

I have hooked my bike up to a Tacx Matic trainer and I am trying to get set up on Zwift but I am struggling!

I bought a cadence and speed sensor (albeit a cheap one off Amazon - https://www.amazon.co.uk/gp/product/B07D4JM194/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1) and couldn’t get the speed sensor working (the cadence sensor worked fine) so couldn’t get moving on Zwift!

**Ideally I would like to set up with my laptop, but worst case scenario I could use my phone.

Can someone advise me what I need to buy to connect my bike to Zwift please?

Nice and cheap to start and if I get in to it I will invest in something a little more reliable/expensive.**

Thanks in advance!
Mick

Hey Micheal!

Welcome to Zwift!

It sounds like you may need to place your spoke magnet in a better position to make sure it’s registering accurately. The user manual should have the info about making sure it’s set up properly. Magnetic sensors can be VERY picky about placement and distance to work.

As for the laptop vs phone situation, you can check all of our minimum requirements here to see if the device will work.

I hope this helps you out some!

Ride On!

1 Like

Good afternoon and welcome to Zwift.

You came to the right place.

So I assume you are trying to connect with Bluetooth built into your laptop. This may or may not work, so lest see if we can get this going at first. Go to the paring screen and unpar the cadence and speed sensor. Now start pedaling to wake up the sensor, pair the speed sensor, don’t worry about cadence we will pair that when every thing is working. If you see the speed sensor but a no signal message, continue to ne next scree as if you want to ride, your rider will not move then press A to go to the paring screen again and re do the paring.

If you don’t have luck with this you can use your phone a bridge, install the zwift companion app from Google play or the app store, that will bridge the bluetooth over wifi (you have to be on the same wifi network)

if all of this does not work I will say get a usb ant+ dongle for your laptop, this is in my view the best way to go.

I figured I couldn’t pair my speed and cadence sensor to my laptop without a dongle (something like this https://www.amazon.co.uk/dp/B07L499Q2P/ref=cm_sw_r_cp_api_i_3o9bDbG15SAYV) - excuse my lack of any tech knowledge - so just hooked it up to my iPhone just to see if it worked. That’s when I got the cadence going but not the speed sensor.

However, after reading your message it seems I could use the companion app as a bridge. :+1:t2::+1:t2:

Is there no easier way to pair it up to your laptop? This seems like a long winded way! To be honest I was ready to dump these sensors and try something new… but I will try it again if you think it may work!

Thanks, when I looked at the placement of the sensor it was about 1.5cm away from the magnet, I read that this may be too far. The way the bike is built I am struggling to shorten this distance.

Is there another product you would recommend?

Can you take a photo of the setup, this sensor should work with most bikes.

a usb ANT+ dongle will be the easiest option.

II am up for buying a dongle if need be… that’s not an issue. However if the sensor isn’t picking up the speed then it still won’t pick it up on the laptop I guess.

Here is my set up… excuse the fact it is currently held together by Blu-Tack - I have already cut the cable ties off in a rage once!!

Short term fix.

Blu-Tack is good. I’ve rotated the speed sensor towards the magnet a little more and it is picking it up!

Put both on top of the chainstay. Cadence sensor close to the crank and speed sensor far back close to the hub.

Will do, thanks for your help. :+1:t2:

1 Like

Let us know if you have any success. Try to align the magnet to the little line on the speed sensor. (if it has a little line)

Think I’m good to go thanks!

After my first couple of mile I realized I had shed a fair bit rubber off my tyre and after a little extra reading I discovered there needed to be more resistance because this was caused by slip?

Thanks for help, I’ll get there in the end and no doubt I’ll be back here soon!

Happy that you got it working.