Blue Matic

Hello! I just got a Blue Matic and am trying to getting going on Zwift. Everything seems to be connected but when I pedal, it still says I have done zero miles and am putting no power out. Any idea what I can do to make it work? Thanks in advance!

I don’t have one of these, but looking at the specs, do you have the cadence and speed sensors? You’ll also need a HR sensor I think. This isn’t a “real” smart trainer. Most folks on zwift want power meters and controllable trainers, like these have https://tacx.com/smart-bike-trainers/. Your setup can probably work, but you won’t get variable resistance going up/down hills and power will be calculated instead of measured.

Good afternoon @Ana_Teixeira

Welcome to the zwift forums.

Lest see if we can get you going.

This may be helpful.

Do you see the speed change in the paring screen. I would suggest un-paring everything and start from scratch, but keep pedaling don’t let the sensors go to sleep.

Hello! Thanks for the reply. I already got everything paired and it does come up on the screen, so I thought it would work. I have uninstalled Zwift and waiting for it to get back on now and pair everything again and see if it works!

did you subscribe to Zwift or are you still using the trail version.

On what device are you installing Zwift?

I am using Windows 10. Just tried Zwift again, still doesn’t work. :frowning:

I am using the trial version.

Did it work before, or is this your first try. I know the avatar will stop riding once your trail expire.

This is my first time.

Yes, I have the speed sensors and cadence.

Can you post a picture of your paring scree while you pedal.

Thanks that was helpful,

It does not seem like Zwift is reading the speed of your sensors.

In the paring screen you should see the RPM and the Speed change while pedaling.
image

Are you conecting using bluetooth, if yes, is the speed and cadence sensor bluetooth compatable.

Oh, wait, sorry. That is the screen the comes up before the ride. During the ride I only see this:

However, on the Zwift companion, this comes up:

So it seems that it’s picking up the cadence bit not the speed

It can bee that your speed sensor is not picking up the magnet, does it work with your cycling computer.

I don’t have a cycling computer, just have it for using with Zwift.

Try a phone app like Wahoo to test the speed sensor.

1 Like

Try to move the sensor closer to the magnet. The magnet should pass close to the little white arrow.

1 Like