New Galaxy Tab S8/plus & Ultra

anyone tested? have any feedback ?

I’m using a Tab S8 Ultra and Zwift works perfectly on it!

Awesome nice big display must be great,

Does not work on my S8+. Just get starting splash screen, can’t swipe it sideways & no prompt or any way to log in. Very disappointed. Worked great on my 6 year old android tablet. Companion app works fine too.

Picked up the s8 plus and it works fine for me just not in split screen mode sort it out zwfit !!

Try loading in dex mode and allow all the app features

Thanks Tommy, appreciate the quick response. After a bit of fiddling about I managed to get past the start up splash screen & log in OK. Seems OK now.

I had the same issue and had to slowly draaaaaaaaaaaaaaaag the screen sideways. it’s bloody hard, but it does work. swipe from right to left with one hand, holding your fingers in place about 2/3rds of the way across, swipe r-l again with the other hand.

Has anyone noticed their battery drains at about 10% per 20-30 minutes even when the tablet is plugged in? Any ideas on a good solution to this? If the rate is consistent is should give plenty of time to get even most decent long routes in, but still, you’d kinda think plugged in would mean little to no battery drain.

Thank you :->

Jon, not noticed the battery drain when plugged in, are you using a 2amp charger?
If you’re using a usb extension in a pc or mac it might struggle to put as much power in as you’re using.
When using screen mirroring on my phone i can burn around 25% per 15 mins unplugged.

And yes the first time installation screen swiping on a Samsung tablet is horrific.

Hey Stuart, apologies for the delay in getting back to you. Got me thinking…

Yup, using a standard wall/plug charger. But it’s plugged into a 4-way extension lead, so wondering whether that might be an issue as it also runs the fan.

Also - do you use a heart rate monitor, and is this Ant+ or Bluetooth? I connect my Wahoo Kickr Core using Bluetooth and HRM (Garmin forerunner) using Ant+… perhaps it’s using both that causes the drainage?

Cheers

Jon

OK, think I’ve solved it. The extension lead was running my tablet charger, trainer and fan. Moved the trainer to a separate socket. Also removed the s-pen from the tablet and didn’t run the Companion app.

Battery held at 100% throughout a 40 minute structured workout on Tempus Fugit.

I then re-connected the S-pen, no impact on the battery. Same for the Companion app. So seems like it was the combination of all 3 things running on the same extension lead.