Neo 2T locking up during sprint

First ride on new neo 2T and every time I sprint around 1000w I get a small slip immediately followed by the trainer ‘locking up’ the resistance is jammed on and I have to turn the trainer off and on again before it frees up.

Tacx app says trainer is up to date…

Anyone know the fix for this?

I don’t know about a specific fix, but you may be able to narrow down the cause to the trainer or a connection issue by trying to replicate the same issue while only using the Tacx app.

Make sure Zwift is not running, open the Tacx app and ensure the NEO2T is responding properly. Get on the bike and try to break the 1000w point to see if it slips again. If it does, it is a Tacx specific problem. If this can be done several times without it slipping, it may be a connection issue between the NEO2T and the Zwift application.

Best of luck…

silly question but is it definatey a 2T? the Neo 2 I believe had this slipping problem (not aware of locking up) but definately slipping problem. The upgraded magnets in the 2T resolved this. I have the 2T and have never experienced ths problem…but then I don’t out out 1000w either!

Ok so just tried again only connected Tacx app by Bluetooth and have same problem, going from 100w to sudden max sprint causing micro slip then flywheel jamming, the red led on the side of unit then flashes red. I’m nothing special in terms of power and can’t believe the 2T is playing up alteady!

Doing a quick search, I’ve found the following:

Tacx NEO2 - Reports of slipping at slow speeds with sudden sprint attempts. No lockup reported with that description, though.

Tacx NEO2T - No reports of slipping or locking up. Red flashing light indicates the cadence sensor is overheating…link provides a tip: https://tacxfaqx.com/knowledge-base/neo-2t-cadence-sensor-overheating/

Other than that, I would contact the manufacturer to see if they have reports of the issue you describe but haven’t posted a solution on the web yet.

All sorted, Tacx app support advised unplug trainer and sprint (no problems), plug power back in then reinstall utility app, update firmware.

All working as it should! Thanks for your quick responses guys

3 Likes

Awesome…now go ride!

:wink: :+1:

Similar Problem, unplugging mine hasn’t seemed to help.

My Tacx Neo 2T trainer has been “locking up” in the middle of my rides-seems to be associated with when I am sprinting or pushing higher power but can happen at any time. When it happens the pedals immediately stop and the resistance is so high i cannot turn them at all. If plugged in, I need to dismount and unplug in order for it to return to a normal resistance again. If not plugged in, the “locking” typically persists for around 1-2sec before resetting and allowing me to pedal again. Very disruptive in group Zwift rides and I am scared to fully sprint or push high power because it is occurring so frequently.

I have already updated the firmware and uninstalled/reinstalled the tax utility app several times. I am currently using firmware version 0.0.34

1 Like

I would contact Tacx through online chat and I’m sure they’ll have it sorted straight away

I have the same problem, in any app or just riding unplugged and unconnected, any big effort >800w in any bike gear causes a slip and lock up, often also throwing my chain off.

Today I had the same problem. I was riding with other friends and during the sprint the trainer flywheel slipped and then got locked. This is very dangerous. You may hurt your knees. I was almost at 800 watts when it happened. Had to stop to disconnect and reconnect the power from the trainer. I also went to the Tacx app and updated the firmware. Need to check if that solved the issue.

I’m sure it will sort it, mines been absolutely flawless ever since that first update