Mobvoi TM Incline Android Connection lost


I’m new with the app an the treadmill (Mobvoi TM Incline).
First I was connecting my treadmill to a Win11 PC and everything is working fine.

Now I want o use ZWIFT with the Android phone and I’m running into problems.
I can connect an everything looks good. But the app will not show the speed of the treadmill.

The treadmill is only connect to one of the system. Bluetooth is off on the Win PC.

Is it a known problem? How can I solve it?
Thank you.

I have the same problem… have you solved it?

Till now I have now solution. I also tried the latest update but it is still not working.

I wonder if the QZ app might help with this. It works as a bridge to connect some treadmills with Zwift.

The developer @Roberto_Viola is on this forum and provides good support. Maybe he knows if Mobvoi owners are using it.

1 Like

qz developer here, let me know if I can help you with the setup

Hello @Roberto_Viola ,

I hope you can help me.
The Android Zwift App is connecting to my treadmill. At that time it shows 0 kmh. When I start to run, it is not showing any speed.
I use a Pixel 4a 5G.

With the Windows program it is working.

Do you have a Idee to fix that?

if you want you can download the trial of qz on your android phone to check if it’s working. if it’s working on qz then you can run zwift on the same device or on windows. i’m not allowed to share here the link to the trial, but send me an email to roberto.viola83 at and I will send you the link

Hi @Roberto_Viola
My Mobvoi TM Incline is coming tomorrow, I have Windows, Apple TV, Android setups ready. (Also Linux env. if needed) I also have nrfconnect as well as qz fitness on my Androids. Please let me know if you need any data dumps to proceed.

when you are ready reach me out by email if you have any issues!

@Roberto_Viola @Marcus_Korner

So, first report. I can confirm that:

  1. Mobvoi TM Incline (native) works well with Zwift on Windows (latest). both speed and incline are being reported correctly, I can see elevation graph in Strava, eventually
  2. Mobvoi TM Incline (native) does not work with Zwift on Android. It connects to the TM in hardware selection dialog, and then shows “Connection error” banner in the top-right corner. Tested on two devices: phone and tablet
  3. Mobvoi TM Incline works well with qz-android. In all configurations - android → same device, android → android, android → windows.
    3.1. Except candence / SPM. It consistently shows 0 SPM, but I have a feeling that it worked once, but don’t remember in which configuration
  4. Inclination control: QZ can control it, but I had to change inclination step from 0.5 to 1 in QZ, because that’s what TM supports.
  5. I haven’t been able to confirm that Zwift can control inclination via QZ. I’ve used all my 3 meetup invites for today, but Incline icon was blinking in QZ (btw, black icon on dark-grey background isn’t readable at all), but haven’t spotted the actual incline control by the Zwift
  6. My Polar HRM sensor didn’t reliably work with QZ: the value was bouncing from 0 to X every second. Both Windows and Android Zwift apps were able to natively use it without any issue.

To be clarified in coming days:

  1. Zwift incline control via “meetup” workaround
  2. Cadence SPM reporting
  3. Apple TV behavior


  1. Even though Zwift Run is free (no paid subscription is needed), will I be able to go through the meetup workaround, given that I need to “ride” for a moment, after my trial is over?
  1. for the SPM I can check it if you can create a ticket with a debug log on github page of QZ
  2. same as 3.
  3. it’s because qz is also reading HR from your treadmil. Enable the setting “disable hrm from machinery”

Let me know if you need help

Github issue: cagnulein/qdomyos-zwift/issues/1900 (Can’t post links yet)